# CVE-2026-25892: Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint

> An unauthenticated attacker can cause a persistent denial of service in Adminer by injecting an array into the version check endpoint, crashing the application for all users.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2026
- **Updated:** 10 Feb 2026
- **Also known as:** GHSA-q4f2-39gr-45jh, UBUNTU-CVE-2026-25892

## What is CVE-2026-25892?

CVE-2026-25892 is a high-severity denial of service vulnerability in vrana adminer, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Adminer is open-source database management software. Adminer v5.4.1 and earlier has a version check mechanism where adminer.org sends signed version info via JavaScript postMessage, which the browser then POSTs to ?script=version. This endpoint lacks origin validation and accepts POST data from any source. An attacker can POST version[] parameter which PHP converts to an array. On next page load, openssl_verify() receives this array instead of string and throws TypeError, returning HTTP 500 to all users. Upgrade to Adminer 5.4.2.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-25892?

2 open source packages ship an affected version, including vrana/adminer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vrana/adminer` | Packagist | From 4.6.2 | 5.4.2 |
| `vrana/adminer` | Packagist | From 4.6.2 | 5.4.2 |

Products: Adminer Adminer.

## How do I fix CVE-2026-25892?

Upgrade vrana/adminer to 5.4.2 or later.

## Is CVE-2026-25892 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25892 exists.

Public exploit code:

- Adminer 4.6.2 - 5.4.1 Unauthenticated Persistent DoS (nuclei): http/cves/2026/CVE-2026-25892.yaml

## Other vulnerabilities in vrana adminer

- [CVE-2021-21311](https://insights.sbomify.com/CVE-2021-21311/): Adminer Server-Side Request Forgery (high 7.2, exploited in the wild)
- [CVE-2018-7667](https://insights.sbomify.com/CVE-2018-7667/): vrana/adminer vulnerable to SSRF by connecting to privileged ports (critical 9.8)
- [CVE-2025-43960](https://insights.sbomify.com/CVE-2025-43960/): Adminer PHP Object Injection issue leads to Denial of Service (high 8.6)
- [CVE-2021-43008](https://insights.sbomify.com/CVE-2021-43008/): Files or Directories Accessible to External Parties in Adminer (high 7.5)
- [CVE-2021-29625](https://insights.sbomify.com/CVE-2021-29625/): XSS in doc_link (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25892 and fix it if it is affected.

What it is: CVE-2026-25892 is a high-severity denial of service vulnerability in vrana adminer, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25892 exists.

Affected packages and fixed versions:
- vrana/adminer (Packagist): affected from 4.6.2; fixed in 5.4.2
- vrana/adminer (Packagist): affected from 4.6.2; fixed in 5.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25892/ (Markdown: https://insights.sbomify.com/CVE-2026-25892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25892
- OSV: https://osv.dev/vulnerability/CVE-2026-25892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25892/
Summaries are generated and may contain mistakes; the official description above is the record.
