# CVE-2026-25894: FUXA Unauthenticated Remote Code Execution via Hardcoded JWT Secret in Default Configuration


- **Severity:** Critical 9.5 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Feb 2026
- **Updated:** 11 Feb 2026
- **Also known as:** GHSA-32cc-x95p-fxcg

## What is CVE-2026-25894?

CVE-2026-25894 is a critical vulnerability in frangoteam FUXA, published on 9 Feb 2026. 

### Official description

FUXA is a web-based Process Visualization (SCADA/HMI/Dashboard) software. An insecure default configuration in FUXA allows an unauthenticated, remote attacker to gain administrative access and execute arbitrary code on the server. This affects FUXA through version 1.2.9 when authentication is enabled, but the administrator JWT secret is not configured. This issue has been patched in FUXA version 1.2.10.

Weakness: CWE-321 (Use of Hard-coded Cryptographic Key), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-25894?

2 open source packages ship an affected version, including fuxa-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fuxa-server` | npm | All versions | 1.2.10 |
| `fuxa-server` | npm | All versions | 1.2.10 |

Products: Frangoteam Fuxa.

## How do I fix CVE-2026-25894?

Upgrade fuxa-server to 1.2.10 or later.

## Is CVE-2026-25894 being exploited?

There is no known exploitation of CVE-2026-25894 in the wild and no public exploit code.

## Other vulnerabilities in frangoteam FUXA

- [CVE-2026-25893](https://insights.sbomify.com/CVE-2026-25893/): FUXA Unauthenticated Remote Code Execution via Admin JWT Minting (critical 10.0)
- [CVE-2025-69985](https://insights.sbomify.com/CVE-2025-69985/): FUXA has JWT Authentication Bypass via HTTP Referer header spoofing (critical 9.8)
- [CVE-2025-69971](https://insights.sbomify.com/CVE-2025-69971/): FUXA has a hardcoded fallback JWT signing secret (critical 9.8)
- [CVE-2023-31719](https://insights.sbomify.com/CVE-2023-31719/): FUXA SQL Injection vulnerability (critical 9.8)
- [CVE-2023-33831](https://insights.sbomify.com/CVE-2023-33831/): A remote command execution (RCE) vulnerability in the /api/runscript endpoint of FUXA (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25894 and fix it if it is affected.

What it is: CVE-2026-25894 is a critical vulnerability in frangoteam FUXA, published on 9 Feb 2026. 
Exploitation: There is no known exploitation of CVE-2026-25894 in the wild and no public exploit code.

Affected packages and fixed versions:
- fuxa-server (npm): affected all versions; fixed in 1.2.10
- fuxa-server (npm): affected all versions; fixed in 1.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25894/ (Markdown: https://insights.sbomify.com/CVE-2026-25894/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25894
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25894
- OSV: https://osv.dev/vulnerability/CVE-2026-25894

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25894/
Summaries are generated and may contain mistakes; the official description above is the record.
