# CVE-2026-25917: Apache Airflow: API extra-links triggers XCom deserialization/class instantiation (Airflow 3.1.5)

> Dag authors can execute arbitrary code in the webserver context by crafting malicious XCom payloads via API extra-links.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** BIT-airflow-2026-25917, ECHO-272a-b69e-0885, GHSA-6ffj-2wg2-w45j, MINI-xj2q-g28v-gj2v, PYSEC-2026-13, PYSEC-2026-2359

## What is CVE-2026-25917?

CVE-2026-25917 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 18 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low.

Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-25917?

5 open source packages ship an affected version, including apache-airflow-core, airflow and apache-airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-core` | PyPI | All versions | 3.2.0 |
| `apache-airflow-core` | PyPI | All versions | 3.2.0 |
| `apache-airflow-core` | PyPI | All versions | 3.2.0 |
| `airflow` | Bitnami | All versions | 3.2.0 |
| `apache-airflow` | PyPI | All versions | 3.2.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-25917?

Upgrade apache-airflow-core to 3.2.0 or later.

## Is CVE-2026-25917 being exploited?

There is no known exploitation of CVE-2026-25917 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25917 and fix it if it is affected.

What it is: CVE-2026-25917 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 18 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25917 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-core (PyPI): affected all versions; fixed in 3.2.0
- apache-airflow-core (PyPI): affected all versions; fixed in 3.2.0
- apache-airflow-core (PyPI): affected all versions; fixed in 3.2.0
- airflow (Bitnami): affected all versions; fixed in 3.2.0
- apache-airflow (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25917/ (Markdown: https://insights.sbomify.com/CVE-2026-25917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25917
- OSV: https://osv.dev/vulnerability/CVE-2026-25917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25917/
Summaries are generated and may contain mistakes; the official description above is the record.
