{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-25931 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-25931 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-25931 is a high-severity vulnerability in streetsidesoftware vscode-spell-checker, published on 9 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-25931 and fix it if it is affected.\n\nWhat it is: CVE-2026-25931 is a high-severity vulnerability in streetsidesoftware vscode-spell-checker, published on 9 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-25931 in the wild and no public exploit code.\n\nAffected product: streetsidesoftware vscode-spell-checker. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-25931/ (Markdown: https://insights.sbomify.com/CVE-2026-25931/index.md)","id":"CVE-2026-25931","markdown":"https://insights.sbomify.com/CVE-2026-25931/index.md","name":"CVE-2026-25931","record":{"aliases":["GHSA-mggq-68mr-58vj"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"VS Code extension","requires_auth":"none","summary":"An attacker can execute arbitrary code by placing a malicious configuration file in an untrusted workspace, bypassing VS Code's workspace trust mechanism.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"},{"id":"CWE-807","name":"Reliance on Untrusted Inputs in a Security Decision"},{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"vscode-spell-checker is a basic spell checker that works well with code and documents. Prior to v4.5.4, DocumentSettings._determineIsTrusted treats the configuration value cSpell.trustedWorkspace as the authoritative trust flag. The value defaults to true (package.json) and is read from workspace configuration each time settings are fetched. The code coerces any truthy value to true and forwards it to ConfigLoader.setIsTrusted , which in turn allows JavaScript/TypeScript configuration files ( .cspell.config.js/.mjs/.ts , etc.) to be located and executed. Because no VS Code workspace-trust state is consulted, an untrusted workspace can keep the flag true and place a malicious .cspell.config.js ; opening the workspace causes the extension host to execute attacker-controlled Node.js code with the user’s privileges. This vulnerability is fixed in v4.5.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"vscode-spell-checker has a workspace-trust bypass Code Execution","id":"CVE-2026-25931","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"GLPI has Stored XSS in Supplier 'Website' field","id":"CVE-2026-25932"},"packages":[],"prev":{"headline":"OpenEMR's Printable LBF Endpoint Leaks Arbitrary Patient Forms","id":"CVE-2026-25930"},"products":["vscode-spell-checker"],"published":"2026-02-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-10","vendors":["streetsidesoftware"]},"summary":"An attacker can execute arbitrary code by placing a malicious configuration file in an untrusted workspace, bypassing VS Code's workspace trust mechanism.","url":"https://insights.sbomify.com/CVE-2026-25931/"}