CVE-2026-25932 GLPI has Stored XSS in Supplier 'Website' field

High 7.2 Published Updated

An authenticated technician can inject malicious scripts into the supplier website field, potentially leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-25932?

CVE-2026-25932 is a high-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 6 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

GLPI is a Free Asset and IT Management Software package. From 0.60 to before 10.0.24, an authenticated technician user can store an XSS payload in a supplier fields. This vulnerability is fixed in 10.0.24.

Weakness: CWE-79, CWE-116

Which versions are affected by CVE-2026-25932?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2026-25932?

No fix has been published for CVE-2026-25932 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-25932 being exploited?

There is no known exploitation of CVE-2026-25932 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-m627-945g-x7xh, UBUNTU-CVE-2026-25932.

Is CVE-2026-25932 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free