# CVE-2026-25934: go-git improperly verifies data integrity values for .idx and .pack files

> Attackers can cause denial of service in go-git by providing corrupted pack files that bypass integrity checks, leading to unexpected errors.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Feb 2026
- **Updated:** 11 Feb 2026
- **Also known as:** CLEANSTART-2026-AR15504, CLEANSTART-2026-BJ08880, CLEANSTART-2026-MJ31309, DEBIAN-CVE-2026-25934, GHSA-37cx-329c-33x3, GO-2026-4473, MINI-22pg-qg98-fhc2, MINI-26rf-c957-jwq7, MINI-2mgf-5gxq-8qh6, MINI-2v3h-hfqq-74w6, MINI-3735-jx47-4c5m, MINI-399j-h3mx-fmgx, MINI-3rgq-rwq9-p89c, MINI-49rx-crg6-23p3, MINI-52qg-vxr3-844j, MINI-5599-f585-gqqv, MINI-587f-h53p-pv58, MINI-5g3q-89m7-vhw3, MINI-5g5x-243c-7x7x, MINI-5hj8-2j6x-2rxm, MINI-5j4m-9mv2-hccx, MINI-6892-3h87-46m2, MINI-697h-p9cj-pmc6, MINI-6c9v-pv6g-r2cw, MINI-6cjp-j2hw-xhjh, MINI-6j8q-5qfx-w98r, MINI-6mvr-r9m5-gf25, MINI-6rxx-2862-f586, MINI-6xgf-mqj2-q9w6, MINI-87mg-3vhw-9frh, MINI-87v7-cjr3-h2r9, MINI-89x7-j98x-jpg8, MINI-8fc5-36ww-x6wh, MINI-8r3v-868g-hg85, MINI-936f-gx74-7j38, MINI-9584-94x7-7w46, MINI-9vr8-h99r-m48j, MINI-c4h7-hx3m-r3mj, MINI-c5ch-j8q9-jw24, MINI-cf6x-jx4g-3qhc, MINI-cvx2-fpfh-x5v5, MINI-f74r-26f8-mqph, MINI-ff68-3x3j-g2xf, MINI-fgfh-9v8v-qmv6, MINI-fxxv-37mv-hfhc, MINI-g3h9-9pg2-rvfv, MINI-gj88-m48r-gxq2, MINI-gv87-xgh8-5q62, MINI-jcm4-4rq9-ffjx, MINI-jx36-hcxf-xqcm, MINI-jx69-jw4h-w7cr, MINI-m5x4-3w8p-2hc6, MINI-mp7j-982w-27w9, MINI-mqxq-v959-jhw5, MINI-mw9r-mv5h-ffcq, MINI-p4fv-v929-q6pv, MINI-p6mp-f63x-3mr9, MINI-p94j-58gr-4vxf, MINI-pmrx-rwq6-c7j5, MINI-pqx6-x442-75pf, MINI-pvjp-4gwx-cg9m, MINI-q5wh-fhpf-7f8c, MINI-qmgm-jmf9-q82v, MINI-qmvf-9fh4-hq54, MINI-qwff-mxjp-7h78, MINI-r3f2-3m8m-j4xp, MINI-r9h4-3v2r-p4h4, MINI-rhg2-6rm3-rvc9, MINI-rqjv-7887-vcqj, MINI-rw6x-hq56-cf94, MINI-v52x-xwv9-9jq2, MINI-vr2x-vpr6-4v7q, MINI-w2cg-43q6-c9fp, MINI-w3pg-mpcv-54vg, MINI-w6p4-wxvj-67fm, MINI-wm23-7vgx-x965, MINI-ww5h-2cqf-j9x4, MINI-wxcg-427g-v9wm, MINI-x6jq-jj87-4hr5, MINI-x75c-6xm4-pvcq, MINI-xc6g-pvfh-p5f9, MINI-xfxw-3c37-4f5h, MINI-xgj4-f298-7gr2, MINI-xhv8-967g-jrw8, MINI-xmx3-fvcv-738j, MINI-xp3q-69ff-6233, MINI-xvph-hc82-gvq7, UBUNTU-CVE-2026-25934

## What is CVE-2026-25934?

CVE-2026-25934 is a medium-severity vulnerability in go-git, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

go-git is a highly extensible git implementation library written in pure Go. Prior to 5.16.5, a vulnerability was discovered in go-git whereby data integrity values for .pack and .idx files were not properly verified. This resulted in go-git potentially consuming corrupted files, which would likely result in unexpected errors such as object not found. For context, clients fetch packfiles from upstream Git servers. Those files contain a checksum of their contents, so that clients can perform integrity checks before consuming it. The pack indexes (.idx) are generated locally by go-git, or the git cli, when new .pack files are received and processed. The integrity checks for both files were not being verified correctly. This vulnerability is fixed in 5.16.5.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2026-25934?

5 open source packages ship an affected version, including github.com/go-git/go-git/v5, github.com/go-git/go-git and github.com/go-git/go-git/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/go-git/go-git/v5` | Go | All versions | 5.16.5 |
| `github.com/go-git/go-git/v5` | Go | All versions | 5.16.5 |
| `github.com/go-git/go-git/v5` | Go | All versions | 5.16.5 |
| `github.com/go-git/go-git` | Go | All versions | None |
| `github.com/go-git/go-git/v4` | Go | All versions | None |

Products: Go-Git Project Go-Git.

## How do I fix CVE-2026-25934?

Upgrade github.com/go-git/go-git/v5 to 5.16.5 or later.

## Is CVE-2026-25934 being exploited?

There is no known exploitation of CVE-2026-25934 in the wild and no public exploit code.

## Other vulnerabilities in go-git

- [CVE-2023-49569](https://insights.sbomify.com/CVE-2023-49569/): Maliciously crafted Git server replies can lead to path traversal and RCE on go-git clients (critical 9.8)
- [CVE-2025-21613](https://insights.sbomify.com/CVE-2025-21613/): go-git has an Argument Injection via the URL field (critical 9.2)
- [CVE-2025-21614](https://insights.sbomify.com/CVE-2025-21614/): go-git clients vulnerable to DoS via maliciously crafted Git server replies (high 7.5)
- [CVE-2023-49568](https://insights.sbomify.com/CVE-2023-49568/): Maliciously crafted Git server replies can cause DoS on go-git clients (high 7.5)
- [CVE-2026-45022](https://insights.sbomify.com/CVE-2026-45022/): go-git: Improper parsing of specially crafted objects may lead to inconsistent interpretation compared to upstream Git (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25934 and fix it if it is affected.

What it is: CVE-2026-25934 is a medium-severity vulnerability in go-git, published on 9 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25934 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/go-git/go-git/v5 (Go): affected all versions; fixed in 5.16.5
- github.com/go-git/go-git/v5 (Go): affected all versions; fixed in 5.16.5
- github.com/go-git/go-git/v5 (Go): affected all versions; fixed in 5.16.5
- github.com/go-git/go-git (Go): affected all versions; no fix listed
- github.com/go-git/go-git/v4 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25934/ (Markdown: https://insights.sbomify.com/CVE-2026-25934/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25934
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25934
- OSV: https://osv.dev/vulnerability/CVE-2026-25934

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25934/
Summaries are generated and may contain mistakes; the official description above is the record.
