CVE-2026-25938 FUXA Unauthenticated Remote Code Execution in Node-RED Integration

Critical 9.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-25938?

CVE-2026-25938 is a critical vulnerability in frangoteam FUXA, published on 9 Feb 2026.

Official description

FUXA is a web-based Process Visualization (SCADA/HMI/Dashboard) software. From 1.2.8 through 1.2.10, an authentication bypass vulnerability in FUXA allows an unauthenticated, remote attacker to execute arbitrary code on the server when the Node-RED plugin is enabled. This has been patched in FUXA version 1.2.11.

Weakness: CWE-306, CWE-290

Which versions are affected by CVE-2026-25938?

2 open source packages ship an affected version, including fuxa-server. It affects 1 product.

PackageAffectedFixed in
fuxa-server npmFrom 1.2.81.2.11
fuxa-server npmFrom 1.2.81.2.11

Products include Frangoteam Fuxa.

How do I fix CVE-2026-25938?

Upgrade fuxa-server to 1.2.11 or later.

Is CVE-2026-25938 being exploited?

There is no known exploitation of CVE-2026-25938 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-v4p5-w6r3-2x4f.

Is CVE-2026-25938 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free