# CVE-2026-25940: jsPDF has a PDF Injection in AcroForm module allows Arbitrary JavaScript Execution (RadioButton.createOption and "AS" property)

> Attackers can inject arbitrary JavaScript into PDFs via unsanitized input in jsPDF's AcroForm module, executing code when victims interact with radio options.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 7 Sep 2026
- **Also known as:** GHSA-p5xg-68wr-hm3m, ROOT-APP-NPM-CVE-2026-25940

## What is CVE-2026-25940?

CVE-2026-25940 is a high-severity code injection vulnerability in parallax jsPDF, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

jsPDF is a library to generate PDFs in JavaScript. Prior to 4.2.0, user control of properties and methods of the Acroform module allows users to inject arbitrary PDF objects, such as JavaScript actions. If given the possibility to pass unsanitized input to one of the following property, a user can inject arbitrary PDF objects, such as JavaScript actions, which are executed when the victim hovers over the radio option. The vulnerability has been fixed in jsPDF@4.2.0. As a workaround, sanitize user input before passing it to the vulnerable API members.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-25940?

2 open source packages ship an affected version, including jspdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jspdf` | npm | All versions | 4.2.0 |
| `jspdf` | npm | All versions | 4.2.0 |

Products: Parall Jspdf.

## How do I fix CVE-2026-25940?

Upgrade jspdf to 4.2.0 or later.

## Is CVE-2026-25940 being exploited?

There is no known exploitation of CVE-2026-25940 in the wild and no public exploit code.

Public exploit code:

- https://github.com/open-flaw/CVE-2026-25940 (github_poc): https://github.com/open-flaw/CVE-2026-25940

## Other vulnerabilities in parallax jsPDF

- [CVE-2026-31938](https://insights.sbomify.com/CVE-2026-31938/): jsPDF has HTML Injection in New Window paths (critical 9.6)
- [CVE-2025-68428](https://insights.sbomify.com/CVE-2025-68428/): jsPDF has Local File Inclusion/Path Traversal vulnerability (critical 9.2)
- [CVE-2026-25535](https://insights.sbomify.com/CVE-2026-25535/): jsPDF Affected by Client-Side/Server-Side Denial of Service via Malicious GIF Dimensions (high 8.7)
- [CVE-2026-24133](https://insights.sbomify.com/CVE-2026-24133/): jsPDF Affected by Denial of Service (DoS) via Unvalidated BMP Dimensions in BMPDecoder (high 8.7)
- [CVE-2025-57810](https://insights.sbomify.com/CVE-2025-57810/): jsPDF Parsing of Corrupt PNGs Leads to Potential Denial of Service (DoS) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25940 and fix it if it is affected.

What it is: CVE-2026-25940 is a high-severity code injection vulnerability in parallax jsPDF, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25940 in the wild and no public exploit code.

Affected packages and fixed versions:
- jspdf (npm): affected all versions; fixed in 4.2.0
- jspdf (npm): affected all versions; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25940/ (Markdown: https://insights.sbomify.com/CVE-2026-25940/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25940
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25940
- OSV: https://osv.dev/vulnerability/CVE-2026-25940

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25940/
Summaries are generated and may contain mistakes; the official description above is the record.
