CVE-2026-25957 Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request
An authenticated attacker can crash the Cube API server by sending a specially crafted request, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25957?
CVE-2026-25957 is a medium-severity denial of service vulnerability in cube-js cube, published on 9 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
Weakness: CWE-755
Which versions are affected by CVE-2026-25957?
4 open source packages ship an affected version, including @cubejs-backend/server-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@cubejs-backend/server-core npm | From 1.1.17 | 1.4.2 |
@cubejs-backend/server-core npm | From 1.1.17 | 1.4.2 |
@cubejs-backend/server-core npm | From 1.5.0 | 1.5.13 |
@cubejs-backend/server-core npm | From 1.5.0 | 1.5.13 |
Products include Cube Cube.js.
How do I fix CVE-2026-25957?
Upgrade @cubejs-backend/server-core to a fixed version for your release line: 1.4.2 or 1.5.13.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-25957 being exploited?
There is no known exploitation of CVE-2026-25957 in the wild and no public exploit code.
Other vulnerabilities in cube-js cube
Sources
Also known as GHSA-9vph-2hvm-x66g.