# CVE-2026-25957: Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request

> An authenticated attacker can crash the Cube API server by sending a specially crafted request, causing a denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2026
- **Updated:** 11 Feb 2026
- **Also known as:** GHSA-9vph-2hvm-x66g

## What is CVE-2026-25957?

CVE-2026-25957 is a medium-severity denial of service vulnerability in cube-js cube, published on 9 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2026-25957?

4 open source packages ship an affected version, including @cubejs-backend/server-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cubejs-backend/server-core` | npm | From 1.1.17 | 1.4.2 |
| `@cubejs-backend/server-core` | npm | From 1.1.17 | 1.4.2 |
| `@cubejs-backend/server-core` | npm | From 1.5.0 | 1.5.13 |
| `@cubejs-backend/server-core` | npm | From 1.5.0 | 1.5.13 |

Products: Cube Cube.js.

## How do I fix CVE-2026-25957?

Upgrade @cubejs-backend/server-core to a fixed version for your release line: 1.4.2 or 1.5.13.

## Is CVE-2026-25957 being exploited?

There is no known exploitation of CVE-2026-25957 in the wild and no public exploit code.

## Other vulnerabilities in cube-js cube

- [CVE-2022-23510](https://insights.sbomify.com/CVE-2022-23510/): SQl injection in cube-js (critical 9.6)
- [CVE-2026-25958](https://insights.sbomify.com/CVE-2026-25958/): Cube privilege escalation via a specially crafted request (high 7.7)
- [CVE-2023-50709](https://insights.sbomify.com/CVE-2023-50709/): Denial of service attack on the cube-api endpoint (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25957 and fix it if it is affected.

What it is: CVE-2026-25957 is a medium-severity denial of service vulnerability in cube-js cube, published on 9 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25957 in the wild and no public exploit code.

Affected packages and fixed versions:
- @cubejs-backend/server-core (npm): affected from 1.1.17; fixed in 1.4.2
- @cubejs-backend/server-core (npm): affected from 1.1.17; fixed in 1.4.2
- @cubejs-backend/server-core (npm): affected from 1.5.0; fixed in 1.5.13
- @cubejs-backend/server-core (npm): affected from 1.5.0; fixed in 1.5.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25957/ (Markdown: https://insights.sbomify.com/CVE-2026-25957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25957
- OSV: https://osv.dev/vulnerability/CVE-2026-25957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25957/
Summaries are generated and may contain mistakes; the official description above is the record.
