{"answers":{"affected":"6 open source packages ship an affected version, including @cubejs-backend/server-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-25958 in the wild and no public exploit code.","fix":"Upgrade @cubejs-backend/server-core to a fixed version for your release line: 1.0.14, 1.4.2 or 1.5.13.","what":"CVE-2026-25958 is a high-severity vulnerability in cube-js cube, published on 9 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-25958 and fix it if it is affected.\n\nWhat it is: CVE-2026-25958 is a high-severity vulnerability in cube-js cube, published on 9 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-25958 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @cubejs-backend/server-core (npm): affected from 0.27.19; fixed in 1.0.14\n- @cubejs-backend/server-core (npm): affected from 0.27.19; fixed in 1.0.14\n- @cubejs-backend/server-core (npm): affected from 1.1.0; fixed in 1.4.2\n- @cubejs-backend/server-core (npm): affected from 1.1.0; fixed in 1.4.2\n- @cubejs-backend/server-core (npm): affected from 1.5.0; fixed in 1.5.13\n- @cubejs-backend/server-core (npm): affected from 1.5.0; fixed in 1.5.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-25958/ (Markdown: https://insights.sbomify.com/CVE-2026-25958/index.md)","id":"CVE-2026-25958","markdown":"https://insights.sbomify.com/CVE-2026-25958/index.md","name":"CVE-2026-25958","record":{"aliases":["GHSA-v226-32c7-x2v7"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Cube semantic layer","requires_auth":"low_privilege","summary":"Attackers with valid API tokens can escalate privileges in Cube via specially crafted requests, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cube.js","vendor":"cube"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-807","name":"Reliance on Untrusted Inputs in a Security Decision"}],"description":"Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cube privilege escalation via a specially crafted request","id":"CVE-2026-25958","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":6,"n_references":1,"next":{"headline":"FreeRDP has heap-use-after-free in xf_cliprdr_provide_data_","id":"CVE-2026-25959"},"packages":[{"ecosystem":"npm","fixed":["1.0.14"],"introduced":["0.27.19"],"last_affected":[],"package":"@cubejs-backend/server-core","purl":null,"source":"GHSA-v226-32c7-x2v7"},{"ecosystem":"npm","fixed":["1.0.14"],"introduced":["0.27.19"],"last_affected":[],"package":"@cubejs-backend/server-core","purl":"pkg:npm/%40cubejs-backend/server-core","source":"GHSA-v226-32c7-x2v7"},{"ecosystem":"npm","fixed":["1.4.2"],"introduced":["1.1.0"],"last_affected":[],"package":"@cubejs-backend/server-core","purl":null,"source":"GHSA-v226-32c7-x2v7"},{"ecosystem":"npm","fixed":["1.4.2"],"introduced":["1.1.0"],"last_affected":[],"package":"@cubejs-backend/server-core","purl":"pkg:npm/%40cubejs-backend/server-core","source":"GHSA-v226-32c7-x2v7"},{"ecosystem":"npm","fixed":["1.5.13"],"introduced":["1.5.0"],"last_affected":[],"package":"@cubejs-backend/server-core","purl":null,"source":"GHSA-v226-32c7-x2v7"},{"ecosystem":"npm","fixed":["1.5.13"],"introduced":["1.5.0"],"last_affected":[],"package":"@cubejs-backend/server-core","purl":"pkg:npm/%40cubejs-backend/server-core","source":"GHSA-v226-32c7-x2v7"}],"prev":{"headline":"Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request","id":"CVE-2026-25957"},"products":["cube"],"published":"2026-02-09","related":[{"cvss_score":9.6,"headline":"SQl injection in cube-js","id":"CVE-2022-23510","kev_date_added":null,"published":"2022-12-09"},{"cvss_score":6.5,"headline":"Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request","id":"CVE-2026-25957","kev_date_added":null,"published":"2026-02-09"},{"cvss_score":6.5,"headline":"Denial of service attack on the cube-api endpoint","id":"CVE-2023-50709","kev_date_added":null,"published":"2023-12-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-11","vendors":["cube-js"]},"summary":"Attackers with valid API tokens can escalate privileges in Cube via specially crafted requests, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2026-25958/"}