# CVE-2026-25960: SSRF Protection Bypass in vLLM

> Attackers can bypass SSRF protections in vLLM by exploiting inconsistent URL parsing between validation and request libraries, potentially accessing internal resources.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-v359-jj2v-j536, PYSEC-2026-3411

## What is CVE-2026-25960?

CVE-2026-25960 is a high-severity server-side request forgery vulnerability in Vllm Vllm, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). The SSRF protection fix for CVE-2026-24779 add in 0.15.1 can be bypassed in the load_from_url_async method due to inconsistent URL parsing behavior between the validation layer and the actual HTTP client. The SSRF fix uses urllib3.util.parse_url() to validate and extract the hostname from user-provided URLs. However, load_from_url_async uses aiohttp for making the actual HTTP requests, and aiohttp internally uses the yarl library for URL parsing. This vulnerability in 0.17.0.

Weakness: CWE-474 (Use of Function with Inconsistent Implementations), CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-25960?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.15.1 | 0.17.0 |
| `vllm` | PyPI | From 0.15.1 | 0.17.0 |
| `vllm` | PyPI | From 0.15.1 | 0.17.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-25960?

Upgrade vllm to 0.17.0 or later.

## Is CVE-2026-25960 being exploited?

There is no known exploitation of CVE-2026-25960 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25960 and fix it if it is affected.

What it is: CVE-2026-25960 is a high-severity server-side request forgery vulnerability in Vllm Vllm, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25960 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.15.1; fixed in 0.17.0
- vllm (PyPI): affected from 0.15.1; fixed in 0.17.0
- vllm (PyPI): affected from 0.15.1; fixed in 0.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25960/ (Markdown: https://insights.sbomify.com/CVE-2026-25960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25960
- OSV: https://osv.dev/vulnerability/CVE-2026-25960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25960/
Summaries are generated and may contain mistakes; the official description above is the record.
