# CVE-2026-25963: Fleet: Authorization Bypass in certificate template batch deletion for team administrators

> A team administrator can delete certificate templates belonging to other teams due to a missing ownership check, disrupting device enrollment and authentication workflows.

- **Severity:** Low 1.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-5jvp-m9h4-253h, GO-2026-4561

## What is CVE-2026-25963?

CVE-2026-25963 is a low-severity missing authorization vulnerability in fleetdm fleet, published on 26 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Fleet is open source device management software. In versions prior to 4.80.1, a broken authorization check in Fleet’s certificate template deletion API could allow a team administrator to delete certificate templates belonging to other teams within the same Fleet instance. Fleet supports certificate templates that are scoped to individual teams. In affected versions, the batch deletion endpoint validated authorization using a user-supplied team identifier but did not verify that the certificate template IDs being deleted actually belonged to that team. As a result, a team administrator could delete certificate templates associated with other teams, potentially disrupting certificate-based workflows such as device enrollment, Wi-Fi authentication, VPN access, or other certificate-dependent configurations for the affected teams. This issue does not allow privilege escalation, access to sensitive data, or compromise of Fleet’s control plane. Impact is limited to integrity and availability of certificate templates across teams. Version 4.80.1 patches the issue. If an immediate upgrade is not possible, administrators should restrict access to certificate template management to trusted users and avoid delegating team administrator permissions where not strictly required.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-25963?

3 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-25963?

Upgrade github.com/fleetdm/fleet/v4 to 4.80.1 or later.

## Is CVE-2026-25963 being exploited?

There is no known exploitation of CVE-2026-25963 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25963 and fix it if it is affected.

What it is: CVE-2026-25963 is a low-severity missing authorization vulnerability in fleetdm fleet, published on 26 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25963 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25963/ (Markdown: https://insights.sbomify.com/CVE-2026-25963/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25963
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25963
- OSV: https://osv.dev/vulnerability/CVE-2026-25963

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25963/
Summaries are generated and may contain mistakes; the official description above is the record.
