# CVE-2026-25967: ImageMagick has stack buffer overflow in FTXT reader via oversized integer field

> A crafted FTXT file triggers a stack buffer overflow in ImageMagick, causing a crash and denial of service.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 23 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-25967, ECHO-58ce-3143-bdfc, GHSA-72hf-fj62-w6j4, JLSEC-2026-954, MINI-x227-pch3-fj85, UBUNTU-CVE-2026-25967

## What is CVE-2026-25967?

CVE-2026-25967 is a high-severity memory corruption vulnerability in Imagemagick Imagemagick, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-15, a stack-based buffer overflow exists in the ImageMagick FTXT image reader. A crafted FTXT file can cause out-of-bounds writes on the stack, leading to a crash. Version 7.1.2-15 contains a patch.

Weakness: CWE-787 (Out-of-bounds Write), CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-25967?

36 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-OpenMP-arm64. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-OpenMP-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.10.3 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.10.3 |
| `agick.NET-Q8-x64` | NuGet | All versions | 14.10.3 |
| `agick.NET-Q8-x64` | NuGet | All versions | 14.10.3 |

Products: Imagemagick Imagemagick.

## How do I fix CVE-2026-25967?

Upgrade Magick.NET-Q16-AnyCPU to 14.10.3 or later.

## Is CVE-2026-25967 being exploited?

There is no known exploitation of CVE-2026-25967 in the wild and no public exploit code.

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25967 and fix it if it is affected.

What it is: CVE-2026-25967 is a high-severity memory corruption vulnerability in Imagemagick Imagemagick, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25967 in the wild and no public exploit code.

Affected packages and fixed versions:
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.10.3
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25967/ (Markdown: https://insights.sbomify.com/CVE-2026-25967/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25967
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25967
- OSV: https://osv.dev/vulnerability/CVE-2026-25967

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25967/
Summaries are generated and may contain mistakes; the official description above is the record.
