# CVE-2026-26000: XWiki Platform affected by click-jacking through CSS injection in comments

> Attackers can inject CSS via comments to overlay the entire wiki with a malicious link, enabling click-jacking attacks against users.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 12 Feb 2026
- **Also known as:** GHSA-74rh-c5rh-88vg

## What is CVE-2026-26000?

CVE-2026-26000 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Prior to 17.9.0, 17.4.6, and 16.10.13, it's possible using comments to inject CSS that would transform the full wiki in a link area leading to a malicious page. This vulnerability is fixed in 17.9.0, 17.4.6, and 16.10.13.

Weakness: CWE-1021 (Improper Restriction of Rendered UI Layers or Frames)

## Which versions are affected by CVE-2026-26000?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web` | Maven | All versions | 16.10.13 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | All versions | 16.10.13 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 17.0.0-rc-1 | 17.4.6 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 17.0.0-rc-1 | 17.4.6 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 17.5.0 | 17.9.0 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 17.5.0 | 17.9.0 |

Products: Xwiki Xwiki.

## How do I fix CVE-2026-26000?

Upgrade org.xwiki.platform:xwiki-platform-web to a fixed version for your release line: 16.10.13, 17.4.6 or 17.9.0.

## Is CVE-2026-26000 being exploited?

There is no known exploitation of CVE-2026-26000 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26000 and fix it if it is affected.

What it is: CVE-2026-26000 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-26000 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web (Maven): affected all versions; fixed in 16.10.13
- org.xwiki.platform:xwiki-platform-web (Maven): affected all versions; fixed in 16.10.13
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 17.0.0-rc-1; fixed in 17.4.6
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 17.0.0-rc-1; fixed in 17.4.6
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 17.5.0; fixed in 17.9.0
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 17.5.0; fixed in 17.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26000/ (Markdown: https://insights.sbomify.com/CVE-2026-26000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26000
- OSV: https://osv.dev/vulnerability/CVE-2026-26000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26000/
Summaries are generated and may contain mistakes; the official description above is the record.
