{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-26002 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-26002 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-26002 is a medium-severity path traversal vulnerability in OSC ondemand, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-26002 and fix it if it is affected.\n\nWhat it is: CVE-2026-26002 is a medium-severity path traversal vulnerability in OSC ondemand, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-26002 in the wild and no public exploit code.\n\nAffected product: OSC ondemand. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-26002/ (Markdown: https://insights.sbomify.com/CVE-2026-26002/index.md)","id":"CVE-2026-26002","markdown":"https://insights.sbomify.com/CVE-2026-26002/index.md","name":"CVE-2026-26002","record":{"aliases":["GHSA-f83q-mhrr-3cr2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"HPC portal","requires_auth":"low_privilege","summary":"Attackers can exploit malicious input in the Files application to navigate directories, potentially reading or modifying unauthorized files.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"open_ondemand","vendor":"osc"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Open OnDemand is an open-source high-performance computing portal. The Files application in OnDemand versions prior to 4.0.9 and 4.1.3 is susceptible to malicious input when navigating to a directory. This has been patched in versions 4.0.9 and 4.1.3.  Versions below this remain susceptible.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"OnDemand susceptible to malicious input when navigating to a directory.","id":"CVE-2026-26002","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"FastGPT Plugin forwarding request is not authenticated, posing a serious risk of attack","id":"CVE-2026-26003"},"packages":[],"prev":{"headline":"GLPI Inventory Plugin has SQL Injection on dropdown_calendar Report","id":"CVE-2026-26001"},"products":["ondemand"],"published":"2026-03-04","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2020-36247","kev_date_added":null,"published":"2021-02-19"},{"cvss_score":7.6,"headline":"Open OnDemand affected by Apache proxy passing sensitive headers","id":"CVE-2025-66029","kev_date_added":null,"published":"2025-12-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-05","vendors":["OSC"]},"summary":"Attackers can exploit malicious input in the Files application to navigate directories, potentially reading or modifying unauthorized files.","url":"https://insights.sbomify.com/CVE-2026-26002/"}