# CVE-2026-26002: OnDemand susceptible to malicious input when navigating to a directory.

> Attackers can exploit malicious input in the Files application to navigate directories, potentially reading or modifying unauthorized files.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Mar 2026
- **Updated:** 5 Mar 2026
- **Also known as:** GHSA-f83q-mhrr-3cr2

## What is CVE-2026-26002?

CVE-2026-26002 is a medium-severity path traversal vulnerability in OSC ondemand, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open OnDemand is an open-source high-performance computing portal. The Files application in OnDemand versions prior to 4.0.9 and 4.1.3 is susceptible to malicious input when navigating to a directory. This has been patched in versions 4.0.9 and 4.1.3.  Versions below this remain susceptible.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-26002?

It affects 1 product.


Products: Osc Open Ondemand.

## How do I fix CVE-2026-26002?

No fix has been published for CVE-2026-26002 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-26002 being exploited?

There is no known exploitation of CVE-2026-26002 in the wild and no public exploit code.

## Other vulnerabilities in OSC ondemand

- [CVE-2020-36247](https://insights.sbomify.com/CVE-2020-36247/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2025-66029](https://insights.sbomify.com/CVE-2025-66029/): Open OnDemand affected by Apache proxy passing sensitive headers (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26002 and fix it if it is affected.

What it is: CVE-2026-26002 is a medium-severity path traversal vulnerability in OSC ondemand, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26002 in the wild and no public exploit code.

Affected product: OSC ondemand. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26002/ (Markdown: https://insights.sbomify.com/CVE-2026-26002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26002
- OSV: https://osv.dev/vulnerability/CVE-2026-26002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26002/
Summaries are generated and may contain mistakes; the official description above is the record.
