CVE-2026-26007 cryptography Subgroup Attack Due to Missing Subgroup Validation for SECT Curves
Attackers can exploit missing subgroup validation in SECT curves to leak private key bits or forge ECDSA signatures, compromising cryptographic security.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-26007?
CVE-2026-26007 is a high-severity vulnerability in pyca cryptography, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Prior to 46.0.5, the public_key_from_numbers (or EllipticCurvePublicNumbers.public_key()), EllipticCurvePublicNumbers.public_key(), load_der_public_key() and load_pem_public_key() functions do not verify that the point belongs to the expected prime-order subgroup of the curve. This missing validation allows an attacker to provide a public key point P from a small-order subgroup. This can lead to security issues in various situations, such as the most commonly used signature verification (ECDSA) and shared key negotiation (ECDH). When the victim computes the shared secret as S = [victim_private_key]P via ECDH, this leaks information about victim_private_key mod (small_subgroup_order). For curves with cofactor > 1, this reveals the least significant bits of the private key. When these weak public keys are used in ECDSA , it's easy to forge signatures on the small subgroup. Only SECT curves are impacted by this. This vulnerability is fixed in 46.0.5.
Which versions are affected by CVE-2026-26007?
3 open source packages ship an affected version, including cryptography. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cryptography PyPI | All versions | 46.0.5 |
cryptography PyPI | All versions | 46.0.5 |
cryptography PyPI | All versions | 46.0.5 |
Linux distribution packages (3)
python-cryptography SUSE:Linux Micro 6.0 | All versions | 42.0.4-3.1 |
python-cryptography SUSE:Linux Micro 6.1 | All versions | 42.0.4-slfo.1.1_3.1 |
python-cryptography openSUSE:Tumbleweed | All versions | 46.0.5-1.1 |
Products include Cryptography.io Cryptography.
How do I fix CVE-2026-26007?
Upgrade cryptography to 46.0.5 or later.
Is CVE-2026-26007 being exploited?
There is no known exploitation of CVE-2026-26007 in the wild and no public exploit code.
Other vulnerabilities in pyca cryptography
- CVE-2020-36242 PyCA Cryptography symmetrically encrypting large values can lead to integer overflow
- CVE-2024-26130 cryptography NULL pointer dereference with pkcs12.serialize_key_and_certificates when called with a non-matching certificate and private key and an hmac_hash override
- CVE-2023-38325 cryptography mishandles SSH certificates
- CVE-2026-39892 cryptography has a buffer overflow if non-contiguous buffers were passed to APIs
- CVE-2023-49083 cryptography vulnerable to NULL-dereference when loading PKCS7 certificates
Sources
Also known as ALPINE-CVE-2026-26007, AZL-77447, AZL-77454, BELL-CVE-2026-26007, CLEANSTART-2026-BX17299, CLEANSTART-2026-XV37407 and 36 more.