# CVE-2026-26007: cryptography Subgroup Attack Due to Missing Subgroup Validation for SECT Curves

> Attackers can exploit missing subgroup validation in SECT curves to leak private key bits or forge ECDSA signatures, compromising cryptographic security.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2026
- **Updated:** 16 Sep 2026
- **Also known as:** ALPINE-CVE-2026-26007, AZL-77447, AZL-77454, BELL-CVE-2026-26007, CLEANSTART-2026-BX17299, CLEANSTART-2026-XV37407, CLSA-2026-1773879456, CLSA-2026-1773879457, CLSA-2026-1774311627, CLSA-2026-1774311633, CLSA-2026-1789557122, CLSA-2026-1790064872, DEBIAN-CVE-2026-26007, ECHO-9290-b93d-4581, GHSA-r6ph-v2qm-q3c2, MINI-2fm3-c6mh-c9pj, MINI-3ff3-q6fq-62rg, MINI-5vgr-73mq-r7cw, MINI-8w42-4cgq-q9w7, MINI-cg8r-2fjf-gh7m, MINI-fgc2-6fc4-rfxp, MINI-gp6v-h33c-xjp3, MINI-h647-7h76-778v, MINI-m3xv-crf9-pj9m, MINI-pjqr-767r-775w, MINI-pwx4-5whv-2p2h, MINI-rw87-3x97-q42x, MINI-v735-28mp-3x5q, MINI-vq6r-2v38-vmr2, OESA-2026-1669, OESA-2026-1670, OESA-2026-1671, OESA-2026-1672, PYSEC-2026-2141, ROOT-APP-PYPI-CVE-2026-26007, ROOT-OS-DEBIAN-12-CVE-2026-26007, SUSE-SU-2026:20655-1, SUSE-SU-2026:20706-1, UBUNTU-CVE-2026-26007, USN-8087-1, USN-8087-3, openSUSE-SU-2026:10205-1

## What is CVE-2026-26007?

CVE-2026-26007 is a high-severity vulnerability in pyca cryptography, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Prior to 46.0.5, the public_key_from_numbers (or EllipticCurvePublicNumbers.public_key()), EllipticCurvePublicNumbers.public_key(), load_der_public_key() and load_pem_public_key() functions do not verify that the point belongs to the expected prime-order subgroup of the curve. This missing validation allows an attacker to provide a public key point P from a small-order subgroup. This can lead to security issues in various situations, such as the most commonly used signature verification (ECDSA) and shared key negotiation (ECDH). When the victim computes the shared secret as S = [victim_private_key]P via ECDH, this leaks information about victim_private_key mod (small_subgroup_order). For curves with cofactor > 1, this reveals the least significant bits of the private key. When these weak public keys are used in ECDSA , it's easy to forge signatures on the small subgroup. Only SECT curves are impacted by this. This vulnerability is fixed in 46.0.5.

Weakness: CWE-354 (Improper Validation of Integrity Check Value), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-26007?

3 open source packages ship an affected version, including cryptography. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cryptography` | PyPI | All versions | 46.0.5 |
| `cryptography` | PyPI | All versions | 46.0.5 |
| `cryptography` | PyPI | All versions | 46.0.5 |
| `python-cryptography` | SUSE:Linux Micro 6.0 | All versions | 42.0.4-3.1 |
| `python-cryptography` | SUSE:Linux Micro 6.1 | All versions | 42.0.4-slfo.1.1_3.1 |
| `python-cryptography` | openSUSE:Tumbleweed | All versions | 46.0.5-1.1 |

Products: Cryptography.io Cryptography.

## How do I fix CVE-2026-26007?

Upgrade cryptography to 46.0.5 or later.

## Is CVE-2026-26007 being exploited?

There is no known exploitation of CVE-2026-26007 in the wild and no public exploit code.

## Other vulnerabilities in pyca cryptography

- [CVE-2020-36242](https://insights.sbomify.com/CVE-2020-36242/): PyCA Cryptography symmetrically encrypting large values can lead to integer overflow (critical 9.1)
- [CVE-2024-26130](https://insights.sbomify.com/CVE-2024-26130/): cryptography NULL pointer dereference with pkcs12.serialize_key_and_certificates when called with a non-matching certificate and private key and an hmac_hash override (high 7.5)
- [CVE-2023-38325](https://insights.sbomify.com/CVE-2023-38325/): cryptography mishandles SSH certificates (high 7.5)
- [CVE-2026-39892](https://insights.sbomify.com/CVE-2026-39892/): cryptography has a buffer overflow if non-contiguous buffers were passed to APIs (medium 6.9)
- [CVE-2023-49083](https://insights.sbomify.com/CVE-2023-49083/): cryptography vulnerable to NULL-dereference when loading PKCS7 certificates (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26007 and fix it if it is affected.

What it is: CVE-2026-26007 is a high-severity vulnerability in pyca cryptography, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26007 in the wild and no public exploit code.

Affected packages and fixed versions:
- cryptography (PyPI): affected all versions; fixed in 46.0.5
- cryptography (PyPI): affected all versions; fixed in 46.0.5
- cryptography (PyPI): affected all versions; fixed in 46.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26007/ (Markdown: https://insights.sbomify.com/CVE-2026-26007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26007
- OSV: https://osv.dev/vulnerability/CVE-2026-26007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26007/
Summaries are generated and may contain mistakes; the official description above is the record.
