CVE-2026-2601 Missing Authorization in GitLab
Authenticated developers can access sensitive deployment data on projects due to improper authorization checks in GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-2601?
CVE-2026-2601 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
GitLab has remediated an issue in GitLab EE affecting all versions from 11.5 before 18.10.7, 18.11 before 18.11.4, and 19.0 before 19.0.1 that under certain conditions could have allowed an authenticated user with developer-role permissions to access sensitive deployment data on projects due to improper authorization checks.
Weakness: CWE-862
Which versions are affected by CVE-2026-2601?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.5.0 | 18.10.7, 18.11.4, 19.0.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2026-2601?
Upgrade gitlab to a fixed version for your release line: 18.10.7, 18.11.4 or 19.0.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-2601 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2601 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2026-2601, GHSA-f3gg-585w-gjj2, UBUNTU-CVE-2026-2601.