# CVE-2026-26014: Pion DTLS uses random nonce generation with AES GCM ciphers risks leaking the authentication key

> Remote attackers can obtain authentication keys and spoof data due to nonce reuse in AES GCM ciphers within the Pion DTLS Go library.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2026
- **Updated:** 13 Feb 2026
- **Also known as:** AZL-77645, AZL-77649, DEBIAN-CVE-2026-26014, GHSA-9f3f-wv7r-qc8r, GO-2026-4479, MINI-4p8c-jvcq-q5q7, MINI-645v-43mw-rfgc, MINI-6486-q68h-v42j, MINI-88fp-mh8f-8xvw, MINI-f3vx-66hr-jhm4, MINI-jr5p-jpph-3mr2, MINI-jvhr-59x3-c4rw, MINI-wpg4-pqp8-4jr6, MINI-wv27-ggfq-g8cv, ROOT-APP-GOBINARY-CVE-2026-26014, UBUNTU-CVE-2026-26014

## What is CVE-2026-26014?

CVE-2026-26014 is a medium-severity vulnerability in pion dtls, published on 11 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pion DTLS is a Go implementation of Datagram Transport Layer Security. Pion DTLS versions v1.0.0 through v3.0.10 and 3.1.0 use random nonce generation with AES GCM ciphers, which makes it easier for remote attackers to obtain the authentication key and spoof data by leveraging the reuse of a nonce in a session and a "forbidden attack". Upgrade to v3.0.11, v3.1.1, or later.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-26014?

11 open source packages ship an affected version, including github.com/pion/dtls/v3, github.com/pion/dtls and github.com/pion/dtls/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pion/dtls/v3` | Go | All versions | 3.0.11 |
| `github.com/pion/dtls/v3` | Go | All versions | 3.0.11 |
| `github.com/pion/dtls/v3` | Go | From 3.0.10 | 3.0.11, 3.1.1 |
| `github.com/pion/dtls/v3` | Go | From 3.1.0 | 3.1.1 |
| `github.com/pion/dtls/v3` | Go | From 3.1.0 | 3.1.1 |
| `github.com/pion/dtls` | Go | All versions | None |
| `github.com/pion/dtls` | Go | All versions to 1.5.4 | None |
| `github.com/pion/dtls` | Go | All versions to 1.5.4 | None |
| `github.com/pion/dtls/v2` | Go | All versions | None |
| `github.com/pion/dtls/v2` | Go | All versions to 2.2.12 | None |
| `github.com/pion/dtls/v2` | Go | All versions to 2.2.12 | None |

Products: Pion Dtls.

## How do I fix CVE-2026-26014?

Upgrade github.com/pion/dtls/v3 to a fixed version for your release line: 3.0.11 or 3.1.1.

## Is CVE-2026-26014 being exploited?

There is no known exploitation of CVE-2026-26014 in the wild and no public exploit code.

## Other vulnerabilities in pion dtls

- [CVE-2019-20786](https://insights.sbomify.com/CVE-2019-20786/): Improper Authenication in Pion DTLS (critical 9.8)
- [CVE-2022-29190](https://insights.sbomify.com/CVE-2022-29190/): Header reconstruction method can be thrown into an infinite loop in Pion DTLS (high 7.5)
- [CVE-2022-29222](https://insights.sbomify.com/CVE-2022-29222/): Improper Certificate Validation in Pion DTLS (medium 5.9)
- [CVE-2022-29189](https://insights.sbomify.com/CVE-2022-29189/): Buffer for inbound DTLS fragments has no limit (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26014 and fix it if it is affected.

What it is: CVE-2026-26014 is a medium-severity vulnerability in pion dtls, published on 11 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26014 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pion/dtls/v3 (Go): affected all versions; fixed in 3.0.11
- github.com/pion/dtls/v3 (Go): affected all versions; fixed in 3.0.11
- github.com/pion/dtls/v3 (Go): affected from 3.0.10; fixed in 3.0.11, 3.1.1
- github.com/pion/dtls/v3 (Go): affected from 3.1.0; fixed in 3.1.1
- github.com/pion/dtls/v3 (Go): affected from 3.1.0; fixed in 3.1.1
- github.com/pion/dtls (Go): affected all versions; no fix listed
- github.com/pion/dtls (Go): affected all versions up to 1.5.4; no fix listed
- github.com/pion/dtls (Go): affected all versions up to 1.5.4; no fix listed
- github.com/pion/dtls/v2 (Go): affected all versions; no fix listed
- github.com/pion/dtls/v2 (Go): affected all versions up to 2.2.12; no fix listed
- github.com/pion/dtls/v2 (Go): affected all versions up to 2.2.12; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26014/ (Markdown: https://insights.sbomify.com/CVE-2026-26014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26014
- OSV: https://osv.dev/vulnerability/CVE-2026-26014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26014/
Summaries are generated and may contain mistakes; the official description above is the record.
