# CVE-2026-26015: Unauthenticated RCE in DocsGPT MCP STDIO Configuration

> An unauthenticated attacker can achieve remote code execution in DocsGPT by bypassing MCP test validation via a malicious payload.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Apr 2026
- **Updated:** 6 May 2026
- **Also known as:** GHSA-gcrq-f296-2j74

## What is CVE-2026-26015?

CVE-2026-26015 is a critical command injection vulnerability in arc53 DocsGPT, published on 29 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DocsGPT is a GPT-powered chat for documentation. From version 0.15.0 to before version 0.16.0, an attacker accessing both the official DocsGPT website or any local and public deployment, can craft a malicious payload bypassing the "MCP test" behavior to achieve arbitrary remote code execution (RCE). This issue has been patched in version 0.16.0.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-26015?

It affects 1 product.


Products: Arc53 Docsgpt.

## How do I fix CVE-2026-26015?

No fix has been published for CVE-2026-26015 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-26015 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26015 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26015 and fix it if it is affected.

What it is: CVE-2026-26015 is a critical command injection vulnerability in arc53 DocsGPT, published on 29 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26015 exists.

Affected product: arc53 DocsGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26015/ (Markdown: https://insights.sbomify.com/CVE-2026-26015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26015
- OSV: https://osv.dev/vulnerability/CVE-2026-26015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26015/
Summaries are generated and may contain mistakes; the official description above is the record.
