# CVE-2026-26016: Pterodactyl Panel Allows Cross-Node Server Configuration Disclosure via Remote API Missing Authorization

> A compromised Wings node token allows attackers to read and modify server configurations across all nodes, leading to data loss and secret exfiltration.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-g7vw-f8p5-c728

## What is CVE-2026-26016?

CVE-2026-26016 is a critical missing authorization vulnerability in pterodactyl panel, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Wings is the server control plane for Pterodactyl, a free, open-source game server management panel. Prior to version 1.12.1, a missing authorization check in multiple controllers allows any user with access to a node secret token to fetch information about any server on a Pterodactyl instance, even if that server is associated with a different node. This issue stems from missing logic to verify that the node requesting server data is the same node that the server is associated with. Any authenticated Wings node can retrieve server installation scripts (potentially containing secret values) and manipulate the installation status of servers belonging to other nodes. Wings nodes may also manipulate the transfer status of servers belonging to other nodes. This vulnerability requires a user to acquire a secret access token for a node. Unless a user gains access to a Wings secret access token they would not be able to access any of these vulnerable endpoints, as every endpoint requires a valid node access token. A single compromised Wings node daemon token (stored in plaintext at `/etc/pterodactyl/config.yml`) grants access to sensitive configuration data of every server on the panel, rather than only to servers that the node has access to. An attacker can use this information to move laterally through the system, send excessive notifications, destroy server data on other nodes, and otherwise exfiltrate secrets that they should not have access to with only a node token. Additionally, triggering a false transfer success causes the panel to delete the server from the source node, resulting in permanent data loss. Users should upgrade to version 1.12.1 to receive a fix.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-283 (Unverified Ownership)

## Which versions are affected by CVE-2026-26016?

2 open source packages ship an affected version, including pterodactyl/panel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pterodactyl/panel` | Packagist | All versions | 1.12.1 |
| `pterodactyl/panel` | Packagist | All versions | 1.12.1 |

Products: Pterodactyl Panel.

## How do I fix CVE-2026-26016?

Upgrade pterodactyl/panel to 1.12.1 or later.

## Is CVE-2026-26016 being exploited?

There is no known exploitation of CVE-2026-26016 in the wild and no public exploit code.

## Other vulnerabilities in pterodactyl panel

- [CVE-2021-41129](https://insights.sbomify.com/CVE-2021-41129/): Authentication bypass in Pterodactyl (high 8.1)
- [CVE-2025-68954](https://insights.sbomify.com/CVE-2025-68954/): Pterodactyl does not revoke SFTP access when server is deleted or permissions reduced (high 7.5)
- [CVE-2019-1020002](https://insights.sbomify.com/CVE-2019-1020002/): Pterodactyl vulnerable to 2FA Sniffing (high 7.5)
- [CVE-2025-69197](https://insights.sbomify.com/CVE-2025-69197/): Pterodactyl TOTPs can be reused during validity window (medium 6.5)
- [CVE-2024-34067](https://insights.sbomify.com/CVE-2024-34067/): Multiple cross site scripting (XSS) vulnerabilities in the admin area of Pterodactyl panel (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26016 and fix it if it is affected.

What it is: CVE-2026-26016 is a critical missing authorization vulnerability in pterodactyl panel, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26016 in the wild and no public exploit code.

Affected packages and fixed versions:
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.12.1
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26016/ (Markdown: https://insights.sbomify.com/CVE-2026-26016/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26016
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26016
- OSV: https://osv.dev/vulnerability/CVE-2026-26016

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26016/
Summaries are generated and may contain mistakes; the official description above is the record.
