# CVE-2026-26018: CoreDNS Loop Detection Denial of Service Vulnerability

> An attacker can crash the CoreDNS server by sending crafted queries that exploit predictable PRNGs in the loop detection plugin.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** AZL-79500, AZL-79529, CLEANSTART-2026-KF12369, CLEANSTART-2026-KZ65152, ECHO-9c6a-4edd-caa0, GHSA-h75p-j8xm-m278, GO-2026-4635, MINI-326m-9r86-v34g, MINI-3mg6-398m-3rpg, MINI-7f84-c9gv-52vm, MINI-7g2c-vv3j-98pr, MINI-7qv3-pj5q-6wfj, MINI-88xw-4v3g-xfmp, MINI-93vp-hmmx-4hq4, MINI-9cxc-w8r3-7h62, MINI-9fqf-2x2g-jwg9, MINI-9x9j-6hg7-9r26, MINI-c4w6-5r37-prr6, MINI-c7p5-vvv6-pjj6, MINI-h3pq-2x29-mf3w, MINI-j868-3cxf-984w, MINI-jp2p-4vp5-rhhv, MINI-m7fj-5c7x-fqcg, MINI-qc6g-6v9w-8v7h, MINI-qhf9-c88r-hxqw, MINI-rpm7-gmg8-v7mq, MINI-v4f9-vw8q-3hgw, OESA-2026-3184

## What is CVE-2026-26018?

CVE-2026-26018 is a high-severity denial of service vulnerability in coredns, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CoreDNS is a DNS server that chains plugins. Prior to version 1.14.2, a denial of service vulnerability exists in CoreDNS's loop detection plugin that allows an attacker to crash the DNS server by sending specially crafted DNS queries. The vulnerability stems from the use of a predictable pseudo-random number generator (PRNG) for generating a secret query name, combined with a fatal error handler that terminates the entire process. This issue has been patched in version 1.14.2.

Weakness: CWE-1241 (Use of Predictable Algorithm in Random Number Generator), CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption), CWE-337 (Predictable Seed in Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2026-26018?

3 open source packages ship an affected version, including github.com/coredns/coredns. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coredns/coredns` | Go | All versions | 1.14.2 |
| `github.com/coredns/coredns` | Go | All versions | 1.14.2 |
| `github.com/coredns/coredns` | Go | All versions | 1.14.2 |

Products: Coredns.io Coredns.

## How do I fix CVE-2026-26018?

Upgrade github.com/coredns/coredns to 1.14.2 or later.

## Is CVE-2026-26018 being exploited?

There is no known exploitation of CVE-2026-26018 in the wild and no public exploit code.

## Other vulnerabilities in coredns

- [CVE-2026-32934](https://insights.sbomify.com/CVE-2026-32934/): CoreDNS DNS-over-QUIC unbounded goroutine growth leads to denial of service (high 8.7)
- [CVE-2026-32936](https://insights.sbomify.com/CVE-2026-32936/): CoreDNS DoH GET path missing size validation causes CPU and memory amplification (high 8.7)
- [CVE-2026-33190](https://insights.sbomify.com/CVE-2026-33190/): CoreDNS TSIG authentication bypass on encrypted DNS transports (high 8.7)
- [CVE-2026-33489](https://insights.sbomify.com/CVE-2026-33489/): CoreDNS transfer plugin subzone ACL bypass via lexicographic zone comparison (high 8.2)
- [CVE-2026-35579](https://insights.sbomify.com/CVE-2026-35579/): CoreDNS TSIG authentication bypass on gRPC, QUIC, DoH, and DoH3 transports (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26018 and fix it if it is affected.

What it is: CVE-2026-26018 is a high-severity denial of service vulnerability in coredns, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26018 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.14.2
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.14.2
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26018/ (Markdown: https://insights.sbomify.com/CVE-2026-26018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26018
- OSV: https://osv.dev/vulnerability/CVE-2026-26018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26018/
Summaries are generated and may contain mistakes; the official description above is the record.
