# CVE-2026-26019: @langchain/community affected by SSRF Bypass in RecursiveUrlLoader via insufficient URL origin validation

> Attackers can bypass URL origin checks in RecursiveUrlLoader to access internal services or attacker-controlled domains via SSRF.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Feb 2026
- **Updated:** 12 Feb 2026
- **Also known as:** CLEANSTART-2026-NM65993, ECHO-fa8c-98dc-ec74, GHSA-gf3v-fwqg-4vh7, MINI-5h3h-3rc2-hc33, MINI-7fx2-8pfx-48jm, MINI-cg5c-5g7r-jwhg, MINI-ghx2-rwjc-9688, MINI-j2p9-f549-xwc3, MINI-p9f7-hq73-5572, MINI-ph5h-fw5m-pfq7, MINI-x5mj-q7gf-69r4, ROOT-APP-NPM-CVE-2026-26019

## What is CVE-2026-26019?

CVE-2026-26019 is a medium-severity server-side request forgery vulnerability in langchain-ai langchainjs, published on 11 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

LangChain is a framework for building LLM-powered applications. Prior to 1.1.14, the RecursiveUrlLoader class in @langchain/community is a web crawler that recursively follows links from a starting URL. Its preventOutside option (enabled by default) is intended to restrict crawling to the same site as the base URL. The implementation used String.startsWith() to compare URLs, which does not perform semantic URL validation. An attacker who controls content on a crawled page could include links to domains that share a string prefix with the target, causing the crawler to follow links to attacker-controlled or internal infrastructure. Additionally, the crawler performed no validation against private or reserved IP addresses. A crawled page could include links targeting cloud metadata services, localhost, or RFC 1918 addresses, and the crawler would fetch them without restriction. This vulnerability is fixed in 1.1.14.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-26019?

2 open source packages ship an affected version, including @langchain/community. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@langchain/community` | npm | All versions | 1.1.14 |
| `@langchain/community` | npm | All versions | 1.1.14 |

Products: Langchain Langchain Community.

## How do I fix CVE-2026-26019?

Upgrade @langchain/community to 1.1.14 or later.

## Is CVE-2026-26019 being exploited?

There is no known exploitation of CVE-2026-26019 in the wild and no public exploit code.

## Other vulnerabilities in langchain-ai langchainjs

- [CVE-2026-27795](https://insights.sbomify.com/CVE-2026-27795/): LangChain Community: redirect chaining can lead to SSRF bypass via RecursiveUrlLoader (medium 4.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26019 and fix it if it is affected.

What it is: CVE-2026-26019 is a medium-severity server-side request forgery vulnerability in langchain-ai langchainjs, published on 11 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-26019 in the wild and no public exploit code.

Affected packages and fixed versions:
- @langchain/community (npm): affected all versions; fixed in 1.1.14
- @langchain/community (npm): affected all versions; fixed in 1.1.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26019/ (Markdown: https://insights.sbomify.com/CVE-2026-26019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26019
- OSV: https://osv.dev/vulnerability/CVE-2026-26019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26019/
Summaries are generated and may contain mistakes; the official description above is the record.
