{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-26020 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-26020 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-26020 is a critical code injection vulnerability in Significant-Gravitas AutoGPT, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-26020 and fix it if it is affected.\n\nWhat it is: CVE-2026-26020 is a critical code injection vulnerability in Significant-Gravitas AutoGPT, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-26020 in the wild and no public exploit code.\n\nAffected product: Significant-Gravitas AutoGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-26020/ (Markdown: https://insights.sbomify.com/CVE-2026-26020/index.md)","id":"CVE-2026-26020","markdown":"https://insights.sbomify.com/CVE-2026-26020/index.md","name":"CVE-2026-26020","record":{"aliases":["GHSA-4crw-9p35-9x54"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"AI agent platform","requires_auth":"low_privilege","summary":"Authenticated users can execute arbitrary code on the server by bypassing disabled block restrictions in graph configurations.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"autogpt_platform","vendor":"agpt"}],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"AutoGPT is a platform that allows users to create, deploy, and manage continuous artificial intelligence agents that automate complex workflows. Prior to 0.6.48, an authenticated user could achieve Remote Code Execution (RCE) on the backend server by embedding a disabled block inside a graph. The BlockInstallationBlock — a development tool capable of writing and importing arbitrary Python code — was marked disabled=True, but graph validation did not enforce this flag. This allowed any authenticated user to bypass the restriction by including the block as a node in a graph, rather than calling the block's execution endpoint directly (which did enforce the flag). This vulnerability is fixed in 0.6.48.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"AutoGPT Affected by Remote Code Execution via Dynamic Module Import in Block Loading (__import__)","id":"CVE-2026-26020","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Prototype pollution in set-in","id":"CVE-2026-26021"},"packages":[],"prev":{"headline":"@langchain/community affected by SSRF Bypass in RecursiveUrlLoader via insufficient URL origin validation","id":"CVE-2026-26019"},"products":["AutoGPT"],"published":"2026-02-12","related":[{"cvss_score":9.3,"headline":"AutoGPT has SSRF vulnerability in ReadRSSFeedBlock","id":"CVE-2025-62615","kev_date_added":null,"published":"2026-02-04"},{"cvss_score":9.3,"headline":"AutoGPT has SSRF vulnerability in SendDiscordFileBlock","id":"CVE-2025-62616","kev_date_added":null,"published":"2026-02-04"},{"cvss_score":8.8,"headline":"Server-Side Template Injection (SSTI) in significant-gravitas/autogpt","id":"CVE-2025-1040","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":8.7,"headline":"AutoGPT has a DoS vulnerability in ReadRSSFeedBlock","id":"CVE-2025-32393","kev_date_added":null,"published":"2026-02-05"},{"cvss_score":8.6,"headline":"AutoGPT is Vulnerable to RCE via Disabled Block Execution","id":"CVE-2026-24780","kev_date_added":null,"published":"2026-01-29"},{"cvss_score":8.6,"headline":"AutoGPT allows leakage of cross-domain cookies and protected headers in requests redirect","id":"CVE-2025-31491","kev_date_added":null,"published":"2025-04-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-12","vendors":["Significant-Gravitas"]},"summary":"Authenticated users can execute arbitrary code on the server by bypassing disabled block restrictions in graph configurations.","url":"https://insights.sbomify.com/CVE-2026-26020/"}