# CVE-2026-26022: Gogs: Stored XSS via data URI in issue comments

> Authenticated users can inject arbitrary JavaScript via data URIs in issue comments, potentially leading to code execution or account takeover.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** GHSA-xrcr-gmf5-2r8j, GO-2026-4620

## What is CVE-2026-26022?

CVE-2026-26022 is a high-severity cross-site scripting vulnerability in gogs, published on 5 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Gogs is an open source self-hosted Git service. Prior to version 0.14.2, a stored cross-site scripting (XSS) vulnerability exists in the comment and issue description functionality. The application's HTML sanitizer explicitly allows data: URI schemes, enabling authenticated users to inject arbitrary JavaScript execution via malicious links. This issue has been patched in version 0.14.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-26022?

3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.2 |
| `gogs.io/gogs` | Go | All versions | 0.14.2 |

Products: Gogs Gogs.

## How do I fix CVE-2026-26022?

Upgrade gogs.io/gogs to 0.14.2 or later.

## Is CVE-2026-26022 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26022 exists.

## Other vulnerabilities in gogs

- [CVE-2025-8110](https://insights.sbomify.com/CVE-2025-8110/): Gogs Path Traversal (high 8.7, exploited in the wild)
- [CVE-2024-56731](https://insights.sbomify.com/CVE-2024-56731/): Gogs deletion of internal files allows remote command execution (critical 10.0)
- [CVE-2022-1884](https://insights.sbomify.com/CVE-2022-1884/): Remote Command Execution in gogs/gogs (critical 10.0)
- [CVE-2022-1986](https://insights.sbomify.com/CVE-2022-1986/): OS Command Injection in gogs/gogs (critical 10.0)
- [CVE-2022-1992](https://insights.sbomify.com/CVE-2022-1992/): Path Traversal in gogs/gogs (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26022 and fix it if it is affected.

What it is: CVE-2026-26022 is a high-severity cross-site scripting vulnerability in gogs, published on 5 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26022 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.2
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26022/ (Markdown: https://insights.sbomify.com/CVE-2026-26022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26022
- OSV: https://osv.dev/vulnerability/CVE-2026-26022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26022/
Summaries are generated and may contain mistakes; the official description above is the record.
