{"answers":{"affected":"2 open source packages ship an affected version, including cryptpad.","exploited":"There is no known exploitation of CVE-2026-26028 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-26028 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-26028 is a medium-severity cross-site scripting vulnerability in cryptpad, published on 20 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-26028 and fix it if it is affected.\n\nWhat it is: CVE-2026-26028 is a medium-severity cross-site scripting vulnerability in cryptpad, published on 20 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-26028 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cryptpad (npm): affected all versions up to 5.9.0; no fix listed\n- cryptpad (npm): affected all versions up to 5.9.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-26028/ (Markdown: https://insights.sbomify.com/CVE-2026-26028/index.md)","id":"CVE-2026-26028","markdown":"https://insights.sbomify.com/CVE-2026-26028/index.md","name":"CVE-2026-26028","record":{"aliases":["GHSA-g2g4-47gv-p72v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"CryptPad collaborative suite","requires_auth":"none","summary":"Attackers can inject arbitrary HTML and execute scripts in CryptPad documents by bypassing the Diffmarked.js sanitizer, compromising user sessions and data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"CryptPad is an end-to-end encrypted collaborative office suite. In versions prior to 2026.2.0, the HTML sanitizer in Diffmarked.js can be bypassed due to incomplete attribute filtering on restricted tags. The sanitizer validates only the src attribute of \u003ciframe\u003e, \u003cvideo\u003e, and \u003caudio\u003e elements, leaving all other attributes unchecked. As a result, an attacker can inject arbitrary HTML through srcdoc, completely defeating CryptPad's intended bounce sandboxing and enabling link injection or other interactive content within user-controlled documents. The root cause lies in how the sanitizer classifies and enforces tag restrictions: although it defines both forbidden and restricted tag lists, \u003ciframe\u003e is treated as \"restricted\" rather than \"forbidden.\" Enforcement then inspects only the src attribute, so pairing a benign blob: src with a malicious srcdoc results in unrestricted rendering. This issue has been fixed in version 2026.2.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"CryptPad: Sanitizer Bypass in Diffmarked.js Allows Arbitrary HTML Injection and Potential XSS","id":"CVE-2026-26028","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"sf-mcp-server has a Command Injection in query_records tool due to unsafe use of child_process.exec","id":"CVE-2026-26029"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["5.9.0"],"package":"cryptpad","purl":null,"source":"GHSA-g2g4-47gv-p72v"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["5.9.0"],"package":"cryptpad","purl":"pkg:npm/cryptpad","source":"GHSA-g2g4-47gv-p72v"}],"prev":{"headline":"GLPI has an Unauthenticated Stored XSS via inventory","id":"CVE-2026-26027"},"products":["cryptpad"],"published":"2026-05-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-20","vendors":["cryptpad"]},"summary":"Attackers can inject arbitrary HTML and execute scripts in CryptPad documents by bypassing the Diffmarked.js sanitizer, compromising user sessions and data.","url":"https://insights.sbomify.com/CVE-2026-26028/"}