# CVE-2026-2603: Keycloak: keycloak: unauthorized authentication via disabled saml identity provider

> Attackers can bypass authentication controls by sending valid SAML responses to disabled identity providers, allowing unauthorized broker logins in Keycloak.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-keycloak-2026-2603, ECHO-3d2b-de07-3bbe, GHSA-x4p7-7chp-64hq, MINI-2cvf-xw78-78f4, MINI-jv86-43mf-v9w2

## What is CVE-2026-2603?

CVE-2026-2603 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Keycloak. A remote attacker could bypass security controls by sending a valid SAML response from an external Identity Provider (IdP) to the Keycloak SAML endpoint for IdP-initiated broker logins. This allows the attacker to complete broker logins even when the SAML Identity Provider is disabled, leading to unauthorized authentication.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-2603?

5 open source packages ship an affected version, including org.keycloak:keycloak-server-spi-private, keycloak and org.keycloak:keycloak-services. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-server-spi-private` | Maven | All versions | 26.5.5 |
| `org.keycloak:keycloak-server-spi-private` | Maven | All versions | 26.5.5 |
| `keycloak` | Bitnami | From 26.2.0 | 26.2.14, 26.4.10 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.5 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.5 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-2603?

Upgrade org.keycloak:keycloak-server-spi-private to 26.5.5 or later.

## Is CVE-2026-2603 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2603 exists.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2603 and fix it if it is affected.

What it is: CVE-2026-2603 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2603 exists.

Affected packages and fixed versions:
- org.keycloak:keycloak-server-spi-private (Maven): affected all versions; fixed in 26.5.5
- org.keycloak:keycloak-server-spi-private (Maven): affected all versions; fixed in 26.5.5
- keycloak (Bitnami): affected from 26.2.0; fixed in 26.2.14, 26.4.10
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.5
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2603/ (Markdown: https://insights.sbomify.com/CVE-2026-2603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2603
- OSV: https://osv.dev/vulnerability/CVE-2026-2603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2603/
Summaries are generated and may contain mistakes; the official description above is the record.
