CVE-2026-26045 Moodle: moodle: improper validation in file restore functionality leading to remote code execution
Authenticated attackers can execute arbitrary server-side code by restoring maliciously crafted backup files in Moodle.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-26045?
CVE-2026-26045 is a high-severity code injection vulnerability in Moodle Moodle, published on 21 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A flaw was identified in Moodle’s backup restore functionality where specially crafted backup files were not properly validated during processing. If a malicious backup file is restored, it could lead to unintended execution of server-side code. Since restore capabilities are typically available to privileged users, exploitation requires authenticated access. Successful exploitation could result in full compromise of the Moodle server.
Weakness: CWE-94
Which versions are affected by CVE-2026-26045?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.5.9 |
moodle/moodle Packagist | All versions | 4.5.9 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.5 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.5 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.2 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.2 |
1 more packages
moodle Bitnami | All versions | 4.5.9, 5.0.5, 5.1.2 |
Products include Moodle Moodle.
How do I fix CVE-2026-26045?
Upgrade moodle/moodle to a fixed version for your release line: 4.5.9, 5.0.5 or 5.1.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-26045 being exploited?
There is no known exploitation of CVE-2026-26045 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2026-26045, GHSA-ggxq-2mg9-8966, UBUNTU-CVE-2026-26045.