# CVE-2026-26045: Moodle: moodle: improper validation in file restore functionality leading to remote code execution

> Authenticated attackers can execute arbitrary server-side code by restoring maliciously crafted backup files in Moodle.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-moodle-2026-26045, GHSA-ggxq-2mg9-8966, UBUNTU-CVE-2026-26045

## What is CVE-2026-26045?

CVE-2026-26045 is a high-severity code injection vulnerability in Moodle Moodle, published on 21 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw was identified in Moodle’s backup restore functionality where specially crafted backup files were not properly validated during processing. If a malicious backup file is restored, it could lead to unintended execution of server-side code. Since restore capabilities are typically available to privileged users, exploitation requires authenticated access. Successful exploitation could result in full compromise of the Moodle server.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-26045?

7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 4.5.9 |
| `moodle/moodle` | Packagist | All versions | 4.5.9 |
| `moodle/moodle` | Packagist | From 5.0.0-beta | 5.0.5 |
| `moodle/moodle` | Packagist | From 5.0.0-beta | 5.0.5 |
| `moodle/moodle` | Packagist | From 5.1.0-beta | 5.1.2 |
| `moodle/moodle` | Packagist | From 5.1.0-beta | 5.1.2 |
| `moodle` | Bitnami | All versions | 4.5.9, 5.0.5, 5.1.2 |

Products: Moodle Moodle.

## How do I fix CVE-2026-26045?

Upgrade moodle/moodle to a fixed version for your release line: 4.5.9, 5.0.5 or 5.1.2.

## Is CVE-2026-26045 being exploited?

There is no known exploitation of CVE-2026-26045 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26045 and fix it if it is affected.

What it is: CVE-2026-26045 is a high-severity code injection vulnerability in Moodle Moodle, published on 21 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26045 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 4.5.9
- moodle/moodle (Packagist): affected all versions; fixed in 4.5.9
- moodle/moodle (Packagist): affected from 5.0.0-beta; fixed in 5.0.5
- moodle/moodle (Packagist): affected from 5.0.0-beta; fixed in 5.0.5
- moodle/moodle (Packagist): affected from 5.1.0-beta; fixed in 5.1.2
- moodle/moodle (Packagist): affected from 5.1.0-beta; fixed in 5.1.2
- moodle (Bitnami): affected all versions; fixed in 4.5.9, 5.0.5, 5.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26045/ (Markdown: https://insights.sbomify.com/CVE-2026-26045/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26045
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26045
- OSV: https://osv.dev/vulnerability/CVE-2026-26045

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26045/
Summaries are generated and may contain mistakes; the official description above is the record.
