CVE-2026-26047 Moodle: moodle: uncontrolled resource consumption in tex formula editor leading to denial of service
An authenticated user can cause a denial of service in Moodle by submitting crafted TeX formulas that exhaust server resources.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-26047?
CVE-2026-26047 is a medium-severity denial of service vulnerability in Moodle Moodle, published on 21 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A denial-of-service vulnerability was identified in Moodle’s TeX formula editor. When rendering TeX content using mimetex, insufficient execution time limits could allow specially crafted formulas to consume excessive server resources. An authenticated user could abuse this behavior to degrade performance or cause service interruption.
Which versions are affected by CVE-2026-26047?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.5.9 |
moodle/moodle Packagist | All versions | 4.5.9 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.5 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.5 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.2 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.2 |
1 more packages
moodle Bitnami | All versions | 4.5.9, 5.0.5, 5.1.2 |
Products include Moodle Moodle.
How do I fix CVE-2026-26047?
Upgrade moodle/moodle to a fixed version for your release line: 4.5.9, 5.0.5 or 5.1.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-26047 being exploited?
There is no known exploitation of CVE-2026-26047 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2026-26047, GHSA-cg8j-5cr2-568q, UBUNTU-CVE-2026-26047.