# CVE-2026-26057: Skill Scanner Unsecured Network Binding Vulnerability

> Unauthenticated attackers can cause denial of service or upload arbitrary files if the API server is enabled due to insecure network binding.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 19 Feb 2026
- **Also known as:** GHSA-ppfx-73j5-fhxc, PYSEC-2026-2415

## What is CVE-2026-26057?

CVE-2026-26057 is a medium-severity vulnerability in cisco-ai-defense skill-scanner, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Skill Scanner is a security scanner for AI Agent Skills that detects prompt injection, data exfiltration, and malicious code patterns. A vulnerability in the API Server of Skill Scanner could allow a unauthenticated, remote attacker to interact with the server API and either trigger a denial of service (DoS) condition or upload arbitrary files. This vulnerability is due to an erroneous binding to multiple interfaces. An attacker could exploit this vulnerability by sending API requests to a device exposing the affected API Server. A successful exploit could allow the attacker to consume an excessive amount of resources (memory starvation) or to upload files to arbitrary folders on the affected device. This vulnerability affects Skill-scanner 1.0.1 and earlier releases when the API Server is enabled. The API Server is not enabled by default. Skill-scanner software releases 1.0.2 and later contain the fix for this vulnerability.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2026-26057?

3 open source packages ship an affected version, including cisco-ai-skill-scanner. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cisco-ai-skill-scanner` | PyPI | All versions | 1.0.2 |
| `cisco-ai-skill-scanner` | PyPI | All versions | 1.0.2 |
| `cisco-ai-skill-scanner` | PyPI | All versions | 1.0.2 |

Products: Cisco Skill Scanner.

## How do I fix CVE-2026-26057?

Upgrade cisco-ai-skill-scanner to 1.0.2 or later.

## Is CVE-2026-26057 being exploited?

There is no known exploitation of CVE-2026-26057 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26057 and fix it if it is affected.

What it is: CVE-2026-26057 is a medium-severity vulnerability in cisco-ai-defense skill-scanner, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26057 in the wild and no public exploit code.

Affected packages and fixed versions:
- cisco-ai-skill-scanner (PyPI): affected all versions; fixed in 1.0.2
- cisco-ai-skill-scanner (PyPI): affected all versions; fixed in 1.0.2
- cisco-ai-skill-scanner (PyPI): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26057/ (Markdown: https://insights.sbomify.com/CVE-2026-26057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26057
- OSV: https://osv.dev/vulnerability/CVE-2026-26057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26057/
Summaries are generated and may contain mistakes; the official description above is the record.
