# CVE-2026-26062: Fleet server may terminate unexpectedly when handling certain gRPC requests

> An authenticated attacker can crash the Fleet server by sending a malformed gRPC request to the PublishLogs endpoint, causing a denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-x67p-9m2r-fxqv, GO-2026-5744

## What is CVE-2026-26062?

CVE-2026-26062 is a high-severity denial of service vulnerability in fleetdm fleet, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fleet is open source device management software. Prior to version 4.81.0, Fleet contained a denial-of-service (DoS) issue in the gRPC Launcher `PublishLogs` endpoint. In affected versions, certain unexpected input values were not handled gracefully, which could cause the Fleet server process to terminate while processing an authenticated request from an enrolled Launcher host. An authenticated attacker with access to any enrolled Launcher node key could cause an immediate and complete denial of service by sending a single gRPC request to the `PublishLogs` endpoint. This vulnerability impacts availability only. There is no exposure of sensitive data, no authentication bypass, no privilege escalation, and no integrity impact. Version 4.81.0 contains a patch. If upgrading immediately is not possible, the following mitigations can reduce exposure.  Restrict network access to the Fleet gRPC endpoint where feasible (for example, limiting inbound access to known host IP ranges); deploy Fleet behind infrastructure that terminates or filters gRPC traffic if Launcher log ingestion is not required; and/or monitor for repeated Fleet process crashes or unexpected restarts indicating potential exploitation.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-26062?

3 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.81.0 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.81.0 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.81.0 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-26062?

Upgrade github.com/fleetdm/fleet/v4 to 4.81.0 or later.

## Is CVE-2026-26062 being exploited?

There is no known exploitation of CVE-2026-26062 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)
- [CVE-2026-23998](https://insights.sbomify.com/CVE-2026-23998/): Fleet has a Windows MDM management endpoint authentication bypass (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26062 and fix it if it is affected.

What it is: CVE-2026-26062 is a high-severity denial of service vulnerability in fleetdm fleet, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26062 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.81.0
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.81.0
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.81.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26062/ (Markdown: https://insights.sbomify.com/CVE-2026-26062/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26062
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26062
- OSV: https://osv.dev/vulnerability/CVE-2026-26062

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26062/
Summaries are generated and may contain mistakes; the official description above is the record.
