{"answers":{"affected":"2 open source packages ship an affected version, including cedipay-core.","exploited":"There is no known exploitation of CVE-2026-26063 in the wild and no public exploit code.","fix":"Upgrade cedipay-core to 1.2.3 or later.","what":"CVE-2026-26063 is a high-severity vulnerability in xpertforextradeinc CediPay, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-26063 and fix it if it is affected.\n\nWhat it is: CVE-2026-26063 is a high-severity vulnerability in xpertforextradeinc CediPay, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-26063 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cedipay-core (npm): affected all versions; fixed in 1.2.3\n- cedipay-core (npm): affected all versions; fixed in 1.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-26063/ (Markdown: https://insights.sbomify.com/CVE-2026-26063/index.md)","id":"CVE-2026-26063","markdown":"https://insights.sbomify.com/CVE-2026-26063/index.md","name":"CVE-2026-26063","record":{"aliases":["GHSA-wvr6-395c-5pxr"],"analysis":{"component_type":"mobile_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Crypto payment app","requires_auth":"none","summary":"Attackers can bypass input validation in the transaction API of the CediPay crypto-to-fiat application, potentially altering transaction data.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"CediPay is a crypto-to-fiat app for the Ghanaian market. A vulnerability in CediPay prior to version 1.2.3 allows attackers to bypass input validation in the transaction API. The issue has been fixed in version 1.2.3. If upgrading is not immediately possible, restrict API access to trusted networks or IP ranges; enforce strict input validation at the application layer; and/or monitor transaction logs for anomalies or suspicious activity. These mitigations reduce exposure but do not fully eliminate the vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CediPay Affected by Improper Input Validation in Payment Processing","id":"CVE-2026-26063","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"calibre: Path Traversal Vulnerability Enables Arbitrary File Write and Remote Code Execution","id":"CVE-2026-26064"},"packages":[{"ecosystem":"npm","fixed":["1.2.3"],"introduced":["0"],"last_affected":[],"package":"cedipay-core","purl":null,"source":"GHSA-wvr6-395c-5pxr"},{"ecosystem":"npm","fixed":["1.2.3"],"introduced":["0"],"last_affected":[],"package":"cedipay-core","purl":"pkg:npm/cedipay-core","source":"GHSA-wvr6-395c-5pxr"}],"prev":{"headline":"Fleet server may terminate unexpectedly when handling certain gRPC requests","id":"CVE-2026-26062"},"products":["CediPay"],"published":"2026-02-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-19","vendors":["xpertforextradeinc"]},"summary":"Attackers can bypass input validation in the transaction API of the CediPay crypto-to-fiat application, potentially altering transaction data.","url":"https://insights.sbomify.com/CVE-2026-26063/"}