# CVE-2026-26063: CediPay Affected by Improper Input Validation in Payment Processing

> Attackers can bypass input validation in the transaction API of the CediPay crypto-to-fiat application, potentially altering transaction data.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 19 Feb 2026
- **Also known as:** GHSA-wvr6-395c-5pxr

## What is CVE-2026-26063?

CVE-2026-26063 is a high-severity vulnerability in xpertforextradeinc CediPay, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CediPay is a crypto-to-fiat app for the Ghanaian market. A vulnerability in CediPay prior to version 1.2.3 allows attackers to bypass input validation in the transaction API. The issue has been fixed in version 1.2.3. If upgrading is not immediately possible, restrict API access to trusted networks or IP ranges; enforce strict input validation at the application layer; and/or monitor transaction logs for anomalies or suspicious activity. These mitigations reduce exposure but do not fully eliminate the vulnerability.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-26063?

2 open source packages ship an affected version, including cedipay-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cedipay-core` | npm | All versions | 1.2.3 |
| `cedipay-core` | npm | All versions | 1.2.3 |

## How do I fix CVE-2026-26063?

Upgrade cedipay-core to 1.2.3 or later.

## Is CVE-2026-26063 being exploited?

There is no known exploitation of CVE-2026-26063 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26063 and fix it if it is affected.

What it is: CVE-2026-26063 is a high-severity vulnerability in xpertforextradeinc CediPay, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26063 in the wild and no public exploit code.

Affected packages and fixed versions:
- cedipay-core (npm): affected all versions; fixed in 1.2.3
- cedipay-core (npm): affected all versions; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26063/ (Markdown: https://insights.sbomify.com/CVE-2026-26063/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26063
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26063
- OSV: https://osv.dev/vulnerability/CVE-2026-26063

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26063/
Summaries are generated and may contain mistakes; the official description above is the record.
