# CVE-2026-26067: October: Safe Mode Bypass via CSS Preprocessor Compilers

> Editors can bypass safe mode to read arbitrary server files via crafted CSS preprocessor imports in October CMS.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-3888-q23f-x7qh

## What is CVE-2026-26067?

CVE-2026-26067 is a medium-severity path traversal vulnerability in octobercms october, published on 21 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

October is a Content Management System (CMS) and web platform. Prior to 3.7.14 and 4.1.10, a server-side information disclosure vulnerability was identified in the handling of CSS preprocessor files. Backend users with Editor permissions could craft .less, .sass, or .scss files that leverage the compiler's import functionality to read arbitrary files from the server. This worked even with cms.safe_mode enabled. This vulnerability is fixed in 3.7.14 and 4.1.10.

Weakness: CWE-863 (Incorrect Authorization), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-26067?

4 open source packages ship an affected version, including october/system.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/system` | Packagist | All versions | 3.7.14 |
| `october/system` | Packagist | All versions | 3.7.14 |
| `october/system` | Packagist | From 4.0.0 | 4.1.10 |
| `october/system` | Packagist | From 4.0.0 | 4.1.10 |

## How do I fix CVE-2026-26067?

Upgrade october/system to a fixed version for your release line: 3.7.14 or 4.1.10.

## Is CVE-2026-26067 being exploited?

There is no known exploitation of CVE-2026-26067 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26067 and fix it if it is affected.

What it is: CVE-2026-26067 is a medium-severity path traversal vulnerability in octobercms october, published on 21 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26067 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/system (Packagist): affected all versions; fixed in 3.7.14
- october/system (Packagist): affected all versions; fixed in 3.7.14
- october/system (Packagist): affected from 4.0.0; fixed in 4.1.10
- october/system (Packagist): affected from 4.0.0; fixed in 4.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26067/ (Markdown: https://insights.sbomify.com/CVE-2026-26067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26067
- OSV: https://osv.dev/vulnerability/CVE-2026-26067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26067/
Summaries are generated and may contain mistakes; the official description above is the record.
