# CVE-2026-26069: Scraparr Readarr Integration exposes sensitive values as metric labels.

> Attackers can read the Readarr API key if the metrics endpoint is public and specific integration settings are active.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Feb 2026
- **Updated:** 13 Feb 2026
- **Also known as:** GHSA-hx24-222f-w5cj

## What is CVE-2026-26069?

CVE-2026-26069 is a critical vulnerability in thecfu scraparr, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Scraparr is a Prometheus Exporter for various components of the *arr Suite. From 3.0.0-beta to before 3.0.2, when the Readarr integration was enabled, the exporter exposed the configured Readarr API key as the alias metric label value. Users were affected only if all of the following conditions are met, Readarr scraping feature was enabled and no alias configured, the exporter’s /metrics endpoint was accessible to external or unauthorized users, and the Readarr instance is externally accessible. If the /metrics endpoint was publicly accessible, the Readarr API key could have been disclosed via exported metrics data. This vulnerability is fixed in 3.0.2.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-26069?

It affects 1 product.


Products: Thecfu Scraparr.

## How do I fix CVE-2026-26069?

No fix has been published for CVE-2026-26069 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-26069 being exploited?

There is no known exploitation of CVE-2026-26069 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26069 and fix it if it is affected.

What it is: CVE-2026-26069 is a critical vulnerability in thecfu scraparr, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26069 in the wild and no public exploit code.

Affected product: thecfu scraparr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26069/ (Markdown: https://insights.sbomify.com/CVE-2026-26069/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26069
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26069
- OSV: https://osv.dev/vulnerability/CVE-2026-26069

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26069/
Summaries are generated and may contain mistakes; the official description above is the record.
