{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-26076 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-26076 is a medium-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-26076 and fix it if it is affected.\n\nWhat it is: CVE-2026-26076 is a medium-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-26076 in the wild and no public exploit code.\n\nAffected product: pendulum-project ntpd-rs. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-26076/ (Markdown: https://insights.sbomify.com/CVE-2026-26076/index.md)","id":"CVE-2026-26076","markdown":"https://insights.sbomify.com/CVE-2026-26076/index.md","name":"CVE-2026-26076","record":{"aliases":["DEBIAN-CVE-2026-26076","GHSA-c7j7-rmvr-fjmv","UBUNTU-CVE-2026-26076"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"NTP server implementation","requires_auth":"none","summary":"Attackers can cause excessive CPU load and degraded performance in ntpd-rs servers by sending malformed NTS packets when NTS is enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ntpd-rs","vendor":"tweedegolf"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"ntpd-rs is a full-featured implementation of the Network Time Protocol. Prior to 1.7.1, an attacker can remotely induce moderate increases (2-4 times above normal) in cpu usage. When having NTS enabled on an ntpd-rs server, an attacker can create malformed NTS packets that take significantly more effort for the server to respond to by requesting a large number of cookies. This can lead to degraded server performance even when a server could otherwise handle the load. This vulnerability is fixed in 1.7.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ntpd-rs affected by excessive CPU load from malformed packets","id":"CVE-2026-26076","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Discourse doesn't ensure webhooks require a token","id":"CVE-2026-26077"},"packages":[],"prev":{"headline":"Cross-Site Request Forgery (CSRF) in FastGPT","id":"CVE-2026-26075"},"products":["ntpd-rs"],"published":"2026-02-12","related":[{"cvss_score":7.5,"headline":"Improper handling of NTS cookie length that could crash the ntpd-rs server","id":"CVE-2023-33192","kev_date_added":null,"published":"2023-05-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-13","vendors":["pendulum-project"]},"summary":"Attackers can cause excessive CPU load and degraded performance in ntpd-rs servers by sending malformed NTS packets when NTS is enabled.","url":"https://insights.sbomify.com/CVE-2026-26076/"}