# CVE-2026-26076: ntpd-rs affected by excessive CPU load from malformed packets

> Attackers can cause excessive CPU load and degraded performance in ntpd-rs servers by sending malformed NTS packets when NTS is enabled.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 13 Feb 2026
- **Also known as:** DEBIAN-CVE-2026-26076, GHSA-c7j7-rmvr-fjmv, UBUNTU-CVE-2026-26076

## What is CVE-2026-26076?

CVE-2026-26076 is a medium-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ntpd-rs is a full-featured implementation of the Network Time Protocol. Prior to 1.7.1, an attacker can remotely induce moderate increases (2-4 times above normal) in cpu usage. When having NTS enabled on an ntpd-rs server, an attacker can create malformed NTS packets that take significantly more effort for the server to respond to by requesting a large number of cookies. This can lead to degraded server performance even when a server could otherwise handle the load. This vulnerability is fixed in 1.7.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-26076?

It affects 1 product.


Products: Tweedegolf Ntpd-Rs.

## How do I fix CVE-2026-26076?

Upgrade to a fixed version.

## Is CVE-2026-26076 being exploited?

There is no known exploitation of CVE-2026-26076 in the wild and no public exploit code.

## Other vulnerabilities in pendulum-project ntpd-rs

- [CVE-2023-33192](https://insights.sbomify.com/CVE-2023-33192/): Improper handling of NTS cookie length that could crash the ntpd-rs server (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26076 and fix it if it is affected.

What it is: CVE-2026-26076 is a medium-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26076 in the wild and no public exploit code.

Affected product: pendulum-project ntpd-rs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26076/ (Markdown: https://insights.sbomify.com/CVE-2026-26076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26076
- OSV: https://osv.dev/vulnerability/CVE-2026-26076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26076/
Summaries are generated and may contain mistakes; the official description above is the record.
