CVE-2026-26078 Discourse has authentication bypass vulnerability in the Patreon plugin webhook endpoint
Attackers can forge webhook signatures when the Patreon secret is blank, allowing unauthorized modification of pledge data and group synchronization.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-26078?
CVE-2026-26078 is a high-severity authentication bypass vulnerability in Discourse Discourse, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, when the `patreon_webhook_secret` site setting is blank, an attacker can forge valid webhook signatures by computing an HMAC-MD5 with an empty string as the key. Since the request body is known to the sender, the attacker can produce a matching signature and send arbitrary webhook payloads. This allows unauthorized creation, modification, or deletion of Patreon pledge data and triggering patron-to-group synchronization. This vulnerability is patched in versions 2025.12.2, 2026.1.1, and 2026.2.0. The fix rejects webhook requests when the webhook secret is not configured, preventing signature forgery with an empty key. As a workaround, configure the `patreon_webhook_secret` site setting with a strong, non-empty secret value. When the secret is non-empty, an attacker cannot forge valid signatures without knowing the secret.
Weakness: CWE-639
Which versions are affected by CVE-2026-26078?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 2025.12.2, 2026.1.1 |
Products include Discourse Discourse.
How do I fix CVE-2026-26078?
Upgrade discourse to a fixed version for your release line: 2025.12.2 or 2026.1.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-26078 being exploited?
There is no known exploitation of CVE-2026-26078 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-26078, GHSA-frx4-wg35-4r68.