# CVE-2026-26078: Discourse has authentication bypass vulnerability in the Patreon plugin webhook endpoint

> Attackers can forge webhook signatures when the Patreon secret is blank, allowing unauthorized modification of pledge data and group synchronization.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** BIT-discourse-2026-26078, GHSA-frx4-wg35-4r68

## What is CVE-2026-26078?

CVE-2026-26078 is a high-severity authentication bypass vulnerability in Discourse Discourse, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, when the `patreon_webhook_secret` site setting is blank, an attacker can forge valid webhook signatures by computing an HMAC-MD5 with an empty string as the key. Since the request body is known to the sender, the attacker can produce a matching signature and send arbitrary webhook payloads. This allows unauthorized creation, modification, or deletion of Patreon pledge data and triggering patron-to-group synchronization. This vulnerability is patched in versions 2025.12.2, 2026.1.1, and 2026.2.0. The fix rejects webhook requests when the webhook secret is not configured, preventing signature forgery with an empty key. As a workaround, configure the `patreon_webhook_secret` site setting with a strong, non-empty secret value. When the secret is non-empty, an attacker cannot forge valid signatures without knowing the secret.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-26078?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2025.12.2, 2026.1.1 |

Products: Discourse Discourse.

## How do I fix CVE-2026-26078?

Upgrade discourse to a fixed version for your release line: 2025.12.2 or 2026.1.1.

## Is CVE-2026-26078 being exploited?

There is no known exploitation of CVE-2026-26078 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26078 and fix it if it is affected.

What it is: CVE-2026-26078 is a high-severity authentication bypass vulnerability in Discourse Discourse, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26078 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2025.12.2, 2026.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26078/ (Markdown: https://insights.sbomify.com/CVE-2026-26078/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26078
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26078
- OSV: https://osv.dev/vulnerability/CVE-2026-26078

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26078/
Summaries are generated and may contain mistakes; the official description above is the record.
