CVE-2026-26080 Denial of service in HAProxy

Low 3.7 Published Updated

An attacker can cause HAProxy to crash or enter an infinite loop by exploiting a varint handling error, leading to service disruption.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-26080?

CVE-2026-26080 is a low-severity denial of service vulnerability in HAProxy, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled. HAProxy Enterprise and ALOHA are also affected.

Weakness: CWE-252

Which versions are affected by CVE-2026-26080?

1 open source package ship an affected version, including haproxy. It affects 3 products.

PackageAffectedFixed in
haproxy BitnamiFrom 3.2.03.2.12, 3.3.3

Products include Haproxy Aloha, Haproxy Haproxy, Haproxy Haproxy Enterprise.

How do I fix CVE-2026-26080?

Upgrade haproxy to a fixed version for your release line: 3.2.12 or 3.3.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-26080 being exploited?

There is no known exploitation of CVE-2026-26080 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as BIT-haproxy-2026-26080, DEBIAN-CVE-2026-26080, GHSA-fhrv-3q89-79q6, MINI-4gg7-p72g-5hq2, MINI-cpxr-566v-7v76.

Is CVE-2026-26080 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free