{"answers":{"affected":"1 open source package ship an affected version, including haproxy. It affects 3 products.","exploited":"There is no known exploitation of CVE-2026-26080 in the wild and no public exploit code.","fix":"Upgrade haproxy to a fixed version for your release line: 3.2.12 or 3.3.3.","what":"CVE-2026-26080 is a low-severity denial of service vulnerability in HAProxy, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-26080 and fix it if it is affected.\n\nWhat it is: CVE-2026-26080 is a low-severity denial of service vulnerability in HAProxy, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-26080 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- haproxy (Bitnami): affected from 3.2.0; fixed in 3.2.12, 3.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-26080/ (Markdown: https://insights.sbomify.com/CVE-2026-26080/index.md)","id":"CVE-2026-26080","markdown":"https://insights.sbomify.com/CVE-2026-26080/index.md","name":"CVE-2026-26080","record":{"aliases":["BIT-haproxy-2026-26080","DEBIAN-CVE-2026-26080","GHSA-fhrv-3q89-79q6","MINI-4gg7-p72g-5hq2","MINI-cpxr-566v-7v76"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HAProxy load balancer","requires_auth":"none","summary":"An attacker can cause HAProxy to crash or enter an infinite loop by exploiting a varint handling error, leading to service disruption.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"aloha","vendor":"haproxy"},{"product":"haproxy","vendor":"haproxy"},{"product":"haproxy_enterprise","vendor":"haproxy"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-252","name":"Unchecked Return Value"}],"description":"HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled. HAProxy Enterprise and ALOHA are also affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-10-27","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-10-27T15:25:41Z","kind":"github_poc","ref":"https://github.com/Zeerg/haproxy-quic-cves-2026","stars":0,"title":"Reproducible lab and network PoCs for HAProxy QUIC CVE-2026-26080 and CVE-2026-26081"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Denial of service in HAProxy","id":"CVE-2026-26080","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Denial of service in HAProxy","id":"CVE-2026-26081"},"packages":[{"ecosystem":"Bitnami","fixed":["3.2.12","3.3.3"],"introduced":["3.2.0","3.3.0"],"last_affected":[],"package":"haproxy","purl":"pkg:bitnami/haproxy","source":"BIT-haproxy-2026-26080"}],"prev":{"headline":"Cross-site scripting in Webmail","id":"CVE-2026-26079"},"products":["HAProxy"],"published":"2026-07-20","related":[{"cvss_score":4.8,"headline":"Denial of service in HAProxy","id":"CVE-2026-26081","kev_date_added":null,"published":"2026-07-20"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-20","vendors":["HAProxy"]},"summary":"An attacker can cause HAProxy to crash or enter an infinite loop by exploiting a varint handling error, leading to service disruption.","url":"https://insights.sbomify.com/CVE-2026-26080/"}