# CVE-2026-26080: Denial of service in HAProxy

> An attacker can cause HAProxy to crash or enter an infinite loop by exploiting a varint handling error, leading to service disruption.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** BIT-haproxy-2026-26080, DEBIAN-CVE-2026-26080, GHSA-fhrv-3q89-79q6, MINI-4gg7-p72g-5hq2, MINI-cpxr-566v-7v76

## What is CVE-2026-26080?

CVE-2026-26080 is a low-severity denial of service vulnerability in HAProxy, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled. HAProxy Enterprise and ALOHA are also affected.

Weakness: CWE-252 (Unchecked Return Value)

## Which versions are affected by CVE-2026-26080?

1 open source package ship an affected version, including haproxy. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haproxy` | Bitnami | From 3.2.0 | 3.2.12, 3.3.3 |

Products: Haproxy Aloha, Haproxy Haproxy, Haproxy Haproxy Enterprise.

## How do I fix CVE-2026-26080?

Upgrade haproxy to a fixed version for your release line: 3.2.12 or 3.3.3.

## Is CVE-2026-26080 being exploited?

There is no known exploitation of CVE-2026-26080 in the wild and no public exploit code.

Public exploit code:

- Reproducible lab and network PoCs for HAProxy QUIC CVE-2026-26080 and CVE-2026-26081 (github_poc): https://github.com/Zeerg/haproxy-quic-cves-2026

## Other vulnerabilities in HAProxy

- [CVE-2026-26081](https://insights.sbomify.com/CVE-2026-26081/): Denial of service in HAProxy (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26080 and fix it if it is affected.

What it is: CVE-2026-26080 is a low-severity denial of service vulnerability in HAProxy, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26080 in the wild and no public exploit code.

Affected packages and fixed versions:
- haproxy (Bitnami): affected from 3.2.0; fixed in 3.2.12, 3.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26080/ (Markdown: https://insights.sbomify.com/CVE-2026-26080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26080
- OSV: https://osv.dev/vulnerability/CVE-2026-26080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26080/
Summaries are generated and may contain mistakes; the official description above is the record.
