CVE-2026-26081 Denial of service in HAProxy
HAProxy lacks a length check for NEW_TOKEN format, allowing attackers to cause a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-26081?
CVE-2026-26081 is a medium-severity denial of service vulnerability in HAProxy, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
HAProxy Community Edition 3.0 through 3.3 before 3.3.3 lacks a length check for the NEW_TOKEN format. HAProxy Enterprise and ALOHA are also affected.
Weakness: CWE-130
Which versions are affected by CVE-2026-26081?
1 open source package ship an affected version, including haproxy. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
haproxy Bitnami | From 3.0.0 | 3.0.16, 3.1.14, 3.2.12, 3.3.3 |
Linux distribution packages (1)
haproxy openSUSE:Tumbleweed | All versions | 3.3.3+git0.465d8e2fc-1.1 |
Products include Haproxy Aloha, Haproxy Haproxy, Haproxy Haproxy Enterprise.
How do I fix CVE-2026-26081?
Upgrade haproxy to a fixed version for your release line: 3.0.16, 3.1.14, 3.2.12 or 3.3.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-26081 being exploited?
There is no known exploitation of CVE-2026-26081 in the wild and no public exploit code.
Other vulnerabilities in HAProxy
Sources
Also known as AZL-93000, BIT-haproxy-2026-26081, DEBIAN-CVE-2026-26081, DSA-6130-1, GHSA-c8q6-qrfh-727c, MINI-2rg3-pf27-g8j5 and 7 more.