{"answers":{"affected":"1 open source package ship an affected version, including haproxy. It affects 3 products.","exploited":"There is no known exploitation of CVE-2026-26081 in the wild and no public exploit code.","fix":"Upgrade haproxy to a fixed version for your release line: 3.0.16, 3.1.14, 3.2.12 or 3.3.3.","what":"CVE-2026-26081 is a medium-severity denial of service vulnerability in HAProxy, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-26081 and fix it if it is affected.\n\nWhat it is: CVE-2026-26081 is a medium-severity denial of service vulnerability in HAProxy, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-26081 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- haproxy (Bitnami): affected from 3.0.0; fixed in 3.0.16, 3.1.14, 3.2.12, 3.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-26081/ (Markdown: https://insights.sbomify.com/CVE-2026-26081/index.md)","id":"CVE-2026-26081","markdown":"https://insights.sbomify.com/CVE-2026-26081/index.md","name":"CVE-2026-26081","record":{"aliases":["AZL-93000","BIT-haproxy-2026-26081","DEBIAN-CVE-2026-26081","DSA-6130-1","GHSA-c8q6-qrfh-727c","MINI-2rg3-pf27-g8j5","MINI-33vf-4m69-6rjr","MINI-4j49-fvrm-gwfx","MINI-6f2w-7cp8-f7mq","OESA-2026-3229","OESA-2026-3230","UBUNTU-CVE-2026-26081","openSUSE-SU-2026:10187-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HAProxy load balancer","requires_auth":"none","summary":"HAProxy lacks a length check for NEW_TOKEN format, allowing attackers to cause a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"aloha","vendor":"haproxy"},{"product":"haproxy","vendor":"haproxy"},{"product":"haproxy_enterprise","vendor":"haproxy"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-130","name":"Improper Handling of Length Parameter Inconsistency"}],"description":"HAProxy Community Edition 3.0 through 3.3 before 3.3.3 lacks a length check for the NEW_TOKEN format. HAProxy Enterprise and ALOHA are also affected.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in HAProxy","id":"CVE-2026-26081","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Missing authorization in FortiSandbox","id":"CVE-2026-26083"},"packages":[{"ecosystem":"Bitnami","fixed":["3.0.16","3.1.14","3.2.12","3.3.3"],"introduced":["3.0.0","3.1.0","3.2.0","3.3.0"],"last_affected":[],"package":"haproxy","purl":"pkg:bitnami/haproxy","source":"BIT-haproxy-2026-26081"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.3.3+git0.465d8e2fc-1.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/opensuse/haproxy\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10187-1"}],"prev":{"headline":"Denial of service in HAProxy","id":"CVE-2026-26080"},"products":["HAProxy"],"published":"2026-07-20","related":[{"cvss_score":3.7,"headline":"Denial of service in HAProxy","id":"CVE-2026-26080","kev_date_added":null,"published":"2026-07-20"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-20","vendors":["HAProxy"]},"summary":"HAProxy lacks a length check for NEW_TOKEN format, allowing attackers to cause a denial of service.","url":"https://insights.sbomify.com/CVE-2026-26081/"}