CVE-2026-2611 Improper Origin Validation in mlflow/mlflow

Critical 9.6 Published Updated

Remote attackers can bypass origin validation to modify MLflow Assistant configuration and execute arbitrary commands via a malicious webpage.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-2611?

CVE-2026-2611 is a critical vulnerability in Lfprojects Mlflow, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In MLflow version 3.9.0, the MLflow Assistant feature introduced improper origin validation in its /ajax-api endpoints. This vulnerability allows a remote attacker to exploit cross-origin requests from a malicious webpage to interact with the MLflow Assistant running on a victim's local machine. By bypassing the loopback-only restriction, the attacker can modify the Assistant's configuration to enable full access, which in turn allows the execution of arbitrary commands via the Claude Code sub-agent. This issue is resolved in version 3.10.0.

Weakness: CWE-940, CWE-346

Which versions are affected by CVE-2026-2611?

4 open source packages ship an affected version, including mlflow. It affects 1 product.

PackageAffectedFixed in
mlflow BitnamiFrom 3.9.03.10.0
mlflow PyPIFrom 3.9.03.10.0
mlflow PyPIFrom 3.9.03.10.0
mlflow PyPIFrom 3.9.03.10.0

Products include Lfprojects Mlflow.

How do I fix CVE-2026-2611?

Upgrade mlflow to 3.10.0 or later.

Is CVE-2026-2611 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2611 exists.

All Lfprojects Mlflow vulnerabilities

Sources

Also known as BIT-mlflow-2026-2611, GHSA-67c5-x5mf-rppq, PYSEC-2026-418.

Is CVE-2026-2611 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free