# CVE-2026-2611: Improper Origin Validation in mlflow/mlflow

> Remote attackers can bypass origin validation to modify MLflow Assistant configuration and execute arbitrary commands via a malicious webpage.

- **Severity:** Critical 9.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-mlflow-2026-2611, GHSA-67c5-x5mf-rppq, PYSEC-2026-418

## What is CVE-2026-2611?

CVE-2026-2611 is a critical vulnerability in Lfprojects Mlflow, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In MLflow version 3.9.0, the MLflow Assistant feature introduced improper origin validation in its /ajax-api endpoints. This vulnerability allows a remote attacker to exploit cross-origin requests from a malicious webpage to interact with the MLflow Assistant running on a victim's local machine. By bypassing the loopback-only restriction, the attacker can modify the Assistant's configuration to enable full access, which in turn allows the execution of arbitrary commands via the Claude Code sub-agent. This issue is resolved in version 3.10.0.

Weakness: CWE-940 (Improper Verification of Source of a Communication Channel), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-2611?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | From 3.9.0 | 3.10.0 |
| `mlflow` | PyPI | From 3.9.0 | 3.10.0 |
| `mlflow` | PyPI | From 3.9.0 | 3.10.0 |
| `mlflow` | PyPI | From 3.9.0 | 3.10.0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2026-2611?

Upgrade mlflow to 3.10.0 or later.

## Is CVE-2026-2611 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2611 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2611 and fix it if it is affected.

What it is: CVE-2026-2611 is a critical vulnerability in Lfprojects Mlflow, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2611 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected from 3.9.0; fixed in 3.10.0
- mlflow (PyPI): affected from 3.9.0; fixed in 3.10.0
- mlflow (PyPI): affected from 3.9.0; fixed in 3.10.0
- mlflow (PyPI): affected from 3.9.0; fixed in 3.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2611/ (Markdown: https://insights.sbomify.com/CVE-2026-2611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2611
- OSV: https://osv.dev/vulnerability/CVE-2026-2611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2611/
Summaries are generated and may contain mistakes; the official description above is the record.
