# CVE-2026-26131: .NET Elevation of Privilege Vulnerability

> An authorized local attacker can elevate privileges due to incorrect default permissions in the .NET runtime.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 19 Jun 2026
- **Also known as:** BIT-dotnet-2026-26131, BIT-dotnet-sdk-2026-26131, GHSA-crjq-wm6x-6qx7, UBUNTU-CVE-2026-26131

## What is CVE-2026-26131?

CVE-2026-26131 is a high-severity vulnerability in Microsoft .Net, published on 10 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incorrect default permissions in .NET allows an authorized attacker to elevate privileges locally.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2026-26131?

14 open source packages ship an affected version, including Microsoft.NetCore.App.Runtime.linux-arm, dotnet and dotnet-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Microsoft.NetCore.App.Runtime.linux-arm` | NuGet | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-arm` | NuGet | From 10.0.0 | 10.0.4 |
| `dotnet` | Bitnami | From 10.0.0 | 10.0.4 |
| `dotnet-sdk` | Bitnami | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-arm64` | NuGet | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-arm64` | NuGet | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-musl-arm` | NuGet | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-musl-arm` | NuGet | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-musl-arm64` | NuGet | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-musl-arm64` | NuGet | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-musl-x64` | NuGet | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-musl-x64` | NuGet | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-x64` | NuGet | From 10.0.0 | 10.0.4 |
| `Microsoft.NetCore.App.Runtime.linux-x64` | NuGet | From 10.0.0 | 10.0.4 |

Products: Microsoft .Net.

## How do I fix CVE-2026-26131?

Upgrade Microsoft.NetCore.App.Runtime.linux-arm to 10.0.4 or later.

## Is CVE-2026-26131 being exploited?

There is no known exploitation of CVE-2026-26131 in the wild and no public exploit code.

## Other vulnerabilities in Microsoft .Net

- [CVE-2024-43498](https://insights.sbomify.com/CVE-2024-43498/): .NET and Visual Studio Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2024-0057](https://insights.sbomify.com/CVE-2024-0057/): NET, .NET Framework, and Visual Studio Security Feature Bypass Vulnerability (critical 9.1)
- [CVE-2026-96957](https://insights.sbomify.com/CVE-2026-96957/): .NET Security Feature Bypass Vulnerability (high 8.8)
- [CVE-2026-69439](https://insights.sbomify.com/CVE-2026-69439/): .NET and Visual Studio Elevation of Privilege Vulnerability (high 8.8)
- [CVE-2026-71328](https://insights.sbomify.com/CVE-2026-71328/): .NET and Visual Studio Remote Code Execution Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26131 and fix it if it is affected.

What it is: CVE-2026-26131 is a high-severity vulnerability in Microsoft .Net, published on 10 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26131 in the wild and no public exploit code.

Affected packages and fixed versions:
- Microsoft.NetCore.App.Runtime.linux-arm (NuGet): affected from 10.0.0; fixed in 10.0.4
- Microsoft.NetCore.App.Runtime.linux-arm (NuGet): affected from 10.0.0; fixed in 10.0.4
- dotnet (Bitnami): affected from 10.0.0; fixed in 10.0.4
- dotnet-sdk (Bitnami): affected from 10.0.0; fixed in 10.0.4
- Microsoft.NetCore.App.Runtime.linux-arm64 (NuGet): affected from 10.0.0; fixed in 10.0.4
- Microsoft.NetCore.App.Runtime.linux-arm64 (NuGet): affected from 10.0.0; fixed in 10.0.4
- Microsoft.NetCore.App.Runtime.linux-musl-arm (NuGet): affected from 10.0.0; fixed in 10.0.4
- Microsoft.NetCore.App.Runtime.linux-musl-arm (NuGet): affected from 10.0.0; fixed in 10.0.4
- Microsoft.NetCore.App.Runtime.linux-musl-arm64 (NuGet): affected from 10.0.0; fixed in 10.0.4
- Microsoft.NetCore.App.Runtime.linux-musl-arm64 (NuGet): affected from 10.0.0; fixed in 10.0.4
- Microsoft.NetCore.App.Runtime.linux-musl-x64 (NuGet): affected from 10.0.0; fixed in 10.0.4
- Microsoft.NetCore.App.Runtime.linux-musl-x64 (NuGet): affected from 10.0.0; fixed in 10.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26131/ (Markdown: https://insights.sbomify.com/CVE-2026-26131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26131
- OSV: https://osv.dev/vulnerability/CVE-2026-26131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26131/
Summaries are generated and may contain mistakes; the official description above is the record.
